Bug 667959

Summary: Preupgrade shouldn't offer versions >= N+3 if it cannot actually do that
Product: [Fedora] Fedora Reporter: Richard W.M. Jones <rjones>
Component: preupgradeAssignee: Richard Hughes <richard>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 14CC: jonathan, richard, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-16 16:03:32 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Richard W.M. Jones 2011-01-07 07:43:00 EST
Description of problem:

Because of bug 527443 I have to install Fedora 10 on a machine
and upgrade it to Fedora 14.  For the first time I used preupgrade
to do this.

Preupgrade offered to installed Fedora 14, so I selected that,
waited about 3 hours while it downloaded packages etc., only
to be told on next reboot that I could upgrade to Fedora 14.

This behaviour is ill-conceived.  It should tell me beforehand
that the upgrade is not possible.

Version-Release number of selected component (if applicable):

preupgrade 1.1.3-1.fc10.noarch going to Fedora 14.

How reproducible:

Once.

Steps to Reproduce:
1. Install Fedora 10.
2. Preupgrade to Fedora 14.
3.
  
Actual results:

Waits 3 hours to tell me it can't do it.

Expected results:

Tell me immediately it can't do it.

Additional info:
Comment 1 Richard W.M. Jones 2011-01-07 07:43:14 EST
Mailing list thread:
http://lists.fedoraproject.org/pipermail/users/2010-November/thread.html#386766
Comment 2 Richard W.M. Jones 2011-01-07 08:16:36 EST
It gets better.  Now preupgrade won't work at all.  It
offers Fedora 12, but just goes to the reboot page and
after reboot gives the same error.
Comment 3 Richard W.M. Jones 2011-01-07 08:33:19 EST
(In reply to comment #2)
> It gets better.  Now preupgrade won't work at all.  It
> offers Fedora 12, but just goes to the reboot page and
> after reboot gives the same error.

This one is resolved by doing 'yum clean all'.
Comment 4 Fedora End Of Life 2012-08-16 16:03:34 EDT
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping