Bug 66968

Summary: NCHardwareList:288:save KeyError: options
Product: [Retired] Red Hat Linux Reporter: Need Real Name <richard_schofield>
Component: redhat-config-networkAssignee: Trond Eivind Glomsrxd <teg>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-07-09 14:47:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 67498    

Description Need Real Name 2002-06-19 10:24:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
This is the debug dump record set...

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 449, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 287, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 302, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", 
line 288, in save
    modules[hw.Card.ModuleName]['options'][confkey] = str(hw.Card.__dict__
[selfkey])
KeyError: options

Local variables in innermost frame:
isdn: <netconfpkg.NCisdnhardware.ConfISDN instance at 851b928>
hw: <netconfpkg.HardwareList.Hardware instance at 84ed638>
selfkey: IRQ
wvdial: <netconfpkg.ConfSMB.ConfSMB instance at 84ed120>
modules: <netconfpkg.NCHardwareList.MyConfModules instance at 84bb558>
confkey: irq
self: [<netconfpkg.HardwareList.Hardware instance at 84ed638>]


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure a netowrk card - any card, the 3 I tried were all different and all 
failed
2.Click Apply
3.Exception Occured window comes up with crash details
	

Actual Results:  Config crashed oou saving nothing and starting nothing.

Expected Results:  Correct Saving of config and the card to come live!  

Additional info:

Comment 1 David Lawrence 2002-07-08 19:37:39 UTC
Changing the component to redhat-config-network which is the proper component
for the neat utility as of 7.3.

Comment 2 Trond Eivind Glomsrxd 2002-07-24 16:47:36 UTC
Didn't happen for all cards, but the current version in  or coming soon to
Rawhide (1.1.10) fixes a few traceback problems.

Comment 3 Trond Eivind Glomsrxd 2002-07-24 16:48:37 UTC
(oh - and please try the public betas to verify the check. Since it wasn't a
common occurence and there was a lack of details, we can't reproduce the exact
scenario)

Comment 4 Harald Hoyer 2002-10-23 09:58:38 UTC
first beta of erratum for 7.3/7.2 is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.