Bug 670361

Summary: GDM crashes in a loop on boot of current Rawhide (F15) nightly composes (2011-01)
Product: [Fedora] Fedora Reporter: Greg` <spowd>
Component: gdmAssignee: jmccann
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: medium    
Version: rawhideCC: awilliam, cschalle, jfrieben, jmccann, nico, petersen, rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-06 01:54:51 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 657616    
Attachments:
Description Flags
greeter.log from a session exhibiting the bug (bzipped) none

Description Greg` 2011-01-17 20:00:11 EST
Description of problem: trying out the latest 2 Nightly composes GDM flickers on both starting from a LiveCD


Version-Release number of selected component (if applicable):


How reproducible:d
Very reproducable

Steps to Reproduce:
1.ownload latest Nightly compose Desktop running it as a LiveCD. once its gets to GDM it will start to flicker
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Williamson 2011-01-18 14:00:29 EST
What's actually happening is it's crashing on start. It 'flickers' because it keeps respawning. I'll attach the crash log in a second.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Adam Williamson 2011-01-18 14:02:33 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2011-01-18 14:10:20 EST
Created attachment 474130 [details]
greeter.log from a session exhibiting the bug (bzipped)
Comment 4 Adam Williamson 2011-01-18 14:11:26 EST
here's just the crash BT extracted from the log:

gdm-simple-greeter[1337]: GLib-GObject-CRITICAL: g_object_ref: assertion `G_IS_OBJECT (object)' failed
aborting...
gdm[1416]: ******************* START **********************************
gdm[1416]: [Thread debugging using libthread_db enabled]
gdm[1416]: [New Thread 0xb6defb70 (LWP 1348)]
gdm[1416]: [New Thread 0xb75f0b70 (LWP 1346)]
gdm[1416]: 0x009f8416 in __kernel_vsyscall ()
gdm[1416]: #0  0x009f8416 in __kernel_vsyscall ()
gdm[1416]: #1  0x008b68ab in waitpid () from /lib/libpthread.so.0
gdm[1416]: #2  0x08079139 in ?? ()
gdm[1416]: #3  0x08079231 in ?? ()
gdm[1416]: #4  <signal handler called>
gdm[1416]: #5  0x00f9d46b in g_logv () from /lib/libglib-2.0.so.0
gdm[1416]: #6  0x00f9d883 in g_log () from /lib/libglib-2.0.so.0
gdm[1416]: #7  0x00f9daae in g_return_if_fail_warning () from /lib/libglib-2.0.so.0
gdm[1416]: #8  0x00b8a703 in g_object_ref () from /lib/libgobject-2.0.so.0
gdm[1416]: #9  0x0807489b in ?? ()
gdm[1416]: #10 0x00ba7a0c in g_cclosure_marshal_VOID__OBJECT () from /lib/libgobject-2.0.so.0
gdm[1416]: #11 0x00b89243 in g_closure_invoke () from /lib/libgobject-2.0.so.0
gdm[1416]: #12 0x00b9cff8 in ?? () from /lib/libgobject-2.0.so.0
gdm[1416]: #13 0x00ba6363 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
gdm[1416]: #14 0x00ba6513 in g_signal_emit () from /lib/libgobject-2.0.so.0
gdm[1416]: #15 0x0807e30e in ?? ()
gdm[1416]: #16 0x0807f201 in ?? ()
gdm[1416]: #17 0x00ba779c in g_cclosure_marshal_VOID__PARAM () from /lib/libgobject-2.0.so.0
gdm[1416]: #18 0x00b89243 in g_closure_invoke () from /lib/libgobject-2.0.so.0
gdm[1416]: #19 0x00b9cff8 in ?? () from /lib/libgobject-2.0.so.0
gdm[1416]: #20 0x00ba6363 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
gdm[1416]: #21 0x00ba6513 in g_signal_emit () from /lib/libgobject-2.0.so.0
gdm[1416]: #22 0x00b8b1b1 in ?? () from /lib/libgobject-2.0.so.0
gdm[1416]: #23 0x00b8a2d0 in ?? () from /lib/libgobject-2.0.so.0
gdm[1416]: #24 0x00b8d871 in g_object_notify () from /lib/libgobject-2.0.so.0
gdm[1416]: #25 0x0807b4a4 in ?? ()
gdm[1416]: #26 0x0807b64f in ?? ()
gdm[1416]: #27 0x00c65a00 in ?? () from /usr/lib/libdbus-glib-1.so.2
gdm[1416]: #28 0x0086f2b2 in ?? () from /lib/libdbus-1.so.3
gdm[1416]: #29 0x0085a367 in ?? () from /lib/libdbus-1.so.3
gdm[1416]: #30 0x0085dc21 in dbus_connection_dispatch () from /lib/libdbus-1.so.3
gdm[1416]: #31 0x00c6069e in ?? () from /usr/lib/libdbus-glib-1.so.2
gdm[1416]: #32 0x00f941e2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
gdm[1416]: #33 0x00f949c8 in ?? () from /lib/libglib-2.0.so.0
gdm[1416]: #34 0x00f9509b in g_main_loop_run () from /lib/libglib-2.0.so.0
gdm[1416]: #35 0x003b0549 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
gdm[1416]: #36 0x080564a6 in ?? ()
gdm[1416]: #37 0x067bae16 in __libc_start_main () from /lib/libc.so.6
gdm[1416]: #38 0x08055dc1 in ?? ()
gdm[1416]: 
gdm[1416]: Thread 3 (Thread 0xb75f0b70 (LWP 1346)):
gdm[1416]: #0  0x009f8416 in __kernel_vsyscall ()
gdm[1416]: No symbol table info available.
gdm[1416]: #1  0x008b2d63 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #2  0x00849f9f in ?? () from /lib/libgthread-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #3  0x00f676ec in ?? () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #4  0x00f6822e in g_async_queue_timed_pop () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #5  0x00fc0ac4 in ?? () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #6  0x00fbe3b0 in ?? () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: .0
gdm[1416]: No symbol table info available.
gdm[1416]: #8  0x068820de in clone () from /lib/libc.so.6
gdm[1416]: No symbol table info available.
gdm[1416]: 
gdm[1416]: Thread 2 (Thread 0xb6defb70 (LWP 1348)):
gdm[1416]: #0  0x009f8416 in __kernel_vsyscall ()
gdm[1416]: No symbol table info available.
gdm[1416]: om /lib/libc.so.6
gdm[1416]: No symbol table info available.
gdm[1416]: #2  0x00fa516c in g_poll () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #3  0x00f94907 in ?? () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: ) from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #5  0x007cb635 in ?? () from /lib/libgio-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #6  0x00fbe3b0 in ?? () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: d () from /lib/libpthread.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #8  0x068820de in clone () from /lib/libc.so.6
gdm[1416]: No symbol table info available.
gdm[1416]: 
gdm[1416]: Thread 1 (Thread 0xb77f1720 (LWP 1337)):
gdm[1416]: #0  0x009f8416 in __kernel_vsyscall ()
gdm[1416]: No symbol table info available.
gdm[1416]: #1  0x008b68ab in waitpid () from /lib/libpthread.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #2  0x08079139 in ?? ()
gdm[1416]: No symbol table info available.
gdm[1416]: #3  0x08079231 in ?? ()
gdm[1416]: No symbol table info available.
gdm[1416]: #4  <signal handler called>
gdm[1416]: le.
gdm[1416]: #5  0x00f9d46b in g_logv () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #6  0x00f9d883 in g_log () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #7  0x00f9daae in g_return_if_fail_warning () from /lib/libglib-2.0.so.0
gdm[1416]: mbol table info available.
gdm[1416]: #8  0x00b8a703 in g_object_ref () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #9  0x0807489b in ?? ()
gdm[1416]: No symbol table info available.
gdm[1416]: 0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #11 0x00b89243 in g_closure_invoke () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #12 0x00b9cff8 in ?? () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: t_valist () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #14 0x00ba6513 in g_signal_emit () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #15 0x0807e30e in ?? ()
gdm[1416]: No symbol table info available.
gdm[1416]: #16 0x0807f201 in ?? ()
gdm[1416]: No symbol table info available.
gdm[1416]: #17 0x00ba779c in g_cclosure_marshal_VOID__PARAM () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: bject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #19 0x00b9cff8 in ?? () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #20 0x00ba6363 in g_signal_emit_valist () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: g_signal_emit () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #22 0x00b8b1b1 in ?? () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #23 0x00b8a2d0 in ?? () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: 0x00b8d871 in g_object_notify () from /lib/libgobject-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #25 0x0807b4a4 in ?? ()
gdm[1416]: No symbol table info available.
gdm[1416]: #26 0x0807b64f in ?? ()
gdm[1416]: No symbol table info available.
gdm[1416]: ib-1.so.2
gdm[1416]: No symbol table info available.
gdm[1416]: #28 0x0086f2b2 in ?? () from /lib/libdbus-1.so.3
gdm[1416]: No symbol table info available.
gdm[1416]: #29 0x0085a367 in ?? () from /lib/libdbus-1.so.3
gdm[1416]: No symbol table info available.
gdm[1416]: #30 0x0085dc21 in dbus_connection_dispatch () from /lib/libdbus-1.so.3
gdm[1416]: No symbol table info available.
gdm[1416]: #31 0x00c6069e in ?? () from /usr/lib/libdbus-glib-1.so.2
gdm[1416]: No symbol table info available.
gdm[1416]: xt_dispatch () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #33 0x00f949c8 in ?? () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #34 0x00f9509b in g_main_loop_run () from /lib/libglib-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: 5 0x003b0549 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
gdm[1416]: No symbol table info available.
gdm[1416]: #36 0x080564a6 in ?? ()
gdm[1416]: No symbol table info available.
gdm[1416]: #37 0x067bae16 in __libc_start_main () from /lib/libc.so.6
gdm[1416]: No symbol table info available.
gdm[1416]: #38 0x08055dc1 in ?? ()
gdm[1416]: No symbol table info available.
gdm[1416]: A debugging session is active.
gdm[1416]: 
gdm[1416]: 	Inferior 1 [process 1337] will be detached.
gdm[1416]: 
gdm[1416]: Quit anyway? (y or n) [answered Y; input not from terminal]
gdm[1416]: ******************* END **********************************




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2011-01-18 14:12:42 EST
this seems to happen almost all the time when booting a recent nightly live image, but occasionally it doesn't happen; there's no obvious difference between sessions when it does and doesn't happen (I just booted the same USB stick twice in a row, in exactly the same way, on exactly the same system, to get the log: first time the bug didn't happen, second time it did). It may be some kind of race condition that just happens to be extremely finely balanced on my test system, I guess.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2011-01-19 05:34:32 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Joachim Frieben 2011-01-19 10:33:16 EST
After booting the system, GDM occasionally comes up with a static login panel, but even then, it happens that it is impossible to login because no user is listed and entering the user name is not possible either.
However, most of the time, GDM simply starts over and over again producing the debug output shown above.
Switching to run level 3 and running startx allows to launch a GNOME session successfully though.
Comment 8 Adam Williamson 2011-01-19 16:17:41 EST
if this could be fixed by next thursday it'd be really helpful, as we have our first test day then.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Jens Petersen 2011-01-19 22:30:40 EST
Interesting thing is only starting loop is there a user in the system.
Since firstboot currently fails, for a normal install there is
no user setup and it doesn't starting crashing until one is added.
Comment 10 Jens Petersen 2011-01-19 22:32:04 EST
ugh:

> Interesting thing is [it] only starts looping [if] there a user in the system.
Comment 11 Adam Williamson 2011-01-19 22:50:15 EST
jens, by policy, the 'priority' field in Fedora Bugzilla is reserved to the use of the maintainer (or maintenance team) responsible for the component, to be used as they see fit - please don't set it on bugs reported against packages you aren't a maintainer of :) thanks.

https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow#Priority_and_Severity

"No-one other than the maintainer or team responsible for a particular bug should change this setting at any point."



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Greg` 2011-01-22 21:10:34 EST
i dont know if anyone wants to close this now but the GDM issue seems to have been fixed. 20110121 fixed it for me ( nightly compose )
Comment 13 Greg` 2011-02-05 20:31:23 EST
Adam

i tested the 20110205 Nightly compose and again i got GDM flickering in a loop again. so i suspect the Bugs back in the latest GDM
Comment 14 Greg` 2011-02-05 22:18:49 EST
(In reply to comment #13)
> Adam
> 
> i tested the 20110205 Nightly compose and again i got GDM flickering in a loop
> again. so i suspect the Bugs back in the latest GDM

the last stable GDM i know of was on the 20110130 LiveCD
Comment 15 Adam Williamson 2011-02-06 01:54:43 EST
Nope, it's a different bug:

https://bugzilla.redhat.com/show_bug.cgi?id=674978

removing /etc/gdm/custom.conf and restarting GDM works around it.

You will this symptom *any* time there's a crasher bug in GDM, because GDM's behaviour is to auto-respawn when it crashes. So seeing this flickering really only tells you that GDM is crashing, it doesn't mean it's the same crash as the LAST time. =)