Bug 670364

Summary: faillog command creates a huge file (/var/log/faillog)
Product: Red Hat Enterprise Linux 5 Reporter: joe.tam
Component: shadow-utilsAssignee: Peter Vrabec <pvrabec>
Status: CLOSED ERRATA QA Contact: Milos Malik <mmalik>
Severity: high Docs Contact:
Priority: high    
Version: 5.5CC: azelinka, mmalik, tmraz
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, under certain circumstances, the faillog utility created huge files. This problem has been fixed; however, the useradd utility can still create large files. To avoid such a situation, use the "-l" option when creating a user with a very high user or group ID (UID or GID).
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-21 01:16:38 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
fix, based on the latest upstream release none

Description joe.tam 2011-01-17 21:25:47 EST
Description of problem:
faillog create a 128GB file, which cause ssh unable to login (like hanging).

On the console, it shows:

Jan 16 20:42:08 web02 kernel: talpa-deny: Error occured while opening /var/log/faillog on behalf of process sshd[5923/5923] owned by 0(0)/0(0)

After remove and create /var/log/faillog, everything resume normal.

Version-Release number of selected component (if applicable):


How reproducible:
Once only

Steps to Reproduce:
1. vi /etc/pam.d/system-auth
2. add auth required pam_tally.so deny=3 before auth sufficient pam_unix.so nullok try_first_pass
3. run:   faillog -m3
  
Actual results:
It created a 128GB file 

Expected results:


Additional info: We upgrade this package (from 4.0.17-15.el5 to 4.0.17-18.el5), however, the problem still exist.
Comment 1 Peter Vrabec 2011-01-20 05:36:37 EST
Created attachment 474435 [details]
fix, based on the latest upstream release
Comment 2 RHEL Product and Program Management 2011-05-31 10:08:01 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 Milos Malik 2012-01-18 10:28:05 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Feel free to change the wording, but do not remove this information from technical notes. It's important.

faillog utility does not create huge files any more, but useradd utility still does. To avoid such a situation please use "-l" option when creating a user with very high UID or GID.
Comment 14 errata-xmlrpc 2012-02-21 01:16:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0244.html
Comment 15 Eliska Slobodova 2012-08-28 05:34:27 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,3 +1 @@
-Feel free to change the wording, but do not remove this information from technical notes. It's important.
+Previously, under certain circumstances, the faillog utility created huge files. This problem has been fixed; however, the useradd utility can still create large files. To avoid such a situation, use the "-l" option when creating a user with a very high user or group ID (UID or GID).-
-faillog utility does not create huge files any more, but useradd utility still does. To avoid such a situation please use "-l" option when creating a user with very high UID or GID.