Bug 672211

Summary: Rebase virt-what in RHEL 6.2
Product: Red Hat Enterprise Linux 6 Reporter: Richard W.M. Jones <rjones>
Component: virt-whatAssignee: Richard W.M. Jones <rjones>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.2CC: jzheng, leiwang, pcao, qwan
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: virt-what-1.11-1.1.el6 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-06 04:57:47 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 671510, 707524    

Description Richard W.M. Jones 2011-01-24 07:20:20 EST
Since we're now carrying 18 patches over virt-what 1.3,
we should rebase virt-what in the next release of RHEL (6.2).

virt-what upstream is very conservatively implemented so
that we always present a stable API (and "ABI") to callers.

The main work goes on adding support for new hypervisors.

We now have detailed regression tests for many hypervisors
which should catch regressions upstream.
Comment 2 Richard W.M. Jones 2011-06-20 10:03:52 EDT
No pm-ack, so no rebase ...
Comment 4 Richard W.M. Jones 2011-06-24 06:24:57 EDT
https://brewweb.devel.redhat.com/taskinfo?taskID=3427278

I have pushed this early so that QA can begin on this
package as soon as possible.  NOTE regressions in this
package could also affect subscription-manager!

The rebased virt-what is the same as upstream virt-what 1.11
+ the single patch that was added to git after 1.11 was
released.  In other words, it's the same as upstream git
d87e9cbae.

Upstream git repo:
http://git.annexia.org/?p=virt-what.git;a=summary
Upstream tarballs:
http://people.redhat.com/~rjones/virt-what/files/
Comment 8 Jinxin Zheng 2011-07-22 05:12:07 EDT
virt-what-1.11-1.1.el6.i686/x86_64 on RHEL 6 host.

# virt-what
kvm

virt-what-1.11-1.1.el6.i686/x86_64 on RHEL 5 host.

# virt-what
kvm
Comment 9 Jinxin Zheng 2011-07-22 05:12:40 EDT
virt-what-1.11-1.1.el6.i686/x86_64 on Xen host.

PV:
# virt-what
xen

HVM:
# virt-what
xen
xen-hvm
Comment 10 Jinxin Zheng 2011-07-22 05:13:00 EDT
virt-what-1.11-1.1.el6.i686/x86_64 on ESX 3.5 host.

# virt-what
vmware

virt-what-1.11-1.1.el6.i686/x86_64 on ESX 4.0 host.

# virt-what
vmware
Comment 11 Jinxin Zheng 2011-07-22 05:13:18 EDT
virt-what-1.11-1.1.el6.i686 on PowerVM x86 world.

# virt-what
powervm_lx86
Comment 12 Jinxin Zheng 2011-07-22 05:13:37 EDT
virt-what-1.11-1.1.el6.s390x on SystemZ (s390x-6s-v1.ss.eng.bos.redhat.com).

# virt-what
ibm_systemz
ibm_systemz-zvm
Comment 13 Jinxin Zheng 2011-07-22 05:14:13 EDT
Hyper-V host environment is being setting up. It should be done within 1 or 2 days.
Comment 14 Richard W.M. Jones 2011-07-22 05:22:03 EDT
(In reply to comment #9)
> virt-what-1.11-1.1.el6.i686/x86_64 on Xen host.
> 
> PV:
> # virt-what
> xen

This one is wrong.  Assuming this is a RHEL 6 guest
(domU) running on a Xen hypervisor, the output should be:

# virt-what
xen
xen-domU

Can you double-check this one?

If it's still failing, can you give me some more details
of the Xen host:

Is it RHEL 5?
Is it Citrix Xen?
Can I get a login to this guest?
Comment 15 Jinxin Zheng 2011-07-22 06:15:53 EDT
I re-checked it. Still no 'xen-domU', either 32 or 64 guest.

It's RHEL6, not RHEL5 or Citrix.
Comment 16 Richard W.M. Jones 2011-07-22 06:28:05 EDT
Thanks for checking this again.

I had a look at this guest, and of course being RHEL 6.1 it's
using pv_ops.  This is in fact a known bug / shortcoming in
virt-what (see [1]).  We don't know how to tell the difference
between dom0 and domU with pv_ops kernels -- it's probably doable
but we don't know how.

So don't worry about this test.  As long as it prints 'xen'
we're OK.

[1] http://git.annexia.org/?p=virt-what.git;a=blob;f=virt-what.in;h=4f381ab4c38cd9d38861a0fbfe764d2c5d5c59b4;hb=HEAD#l190
Comment 17 Jinxin Zheng 2011-07-25 00:56:34 EDT
virt-what-1.11-1.1.el6.i686/x86_64 on Hyper-V.

# virt-what
hyperv

Now all the hypervisors and guests are tested, moving this to VERIFIED.
Comment 18 errata-xmlrpc 2011-12-06 04:57:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1556.html