Bug 672662

Summary: openssh-5.8p1 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: opensshAssignee: Jan F. Chadima <jchadima>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: jchadima, mgrepl, mike.cloaked, tmraz
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-14 10:41:22 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Upstream Release Monitoring 2011-01-25 14:53:26 EST
Latest upstream release: 5.7p1
Current version in Fedora Rawhide: 5.6p1
URL: http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Jan F. Chadima 2011-01-25 16:46:20 EST
I know about the release, but it will be delayed in fedora, because of great changes in the source code.. I'll have to check each piece of patch against the new sources.
Comment 2 Upstream Release Monitoring 2011-02-05 05:15:49 EST
Latest upstream release: 5.8p1
Current version in Fedora Rawhide: 5.6p1
URL: http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 3 Jan F. Chadima 2011-02-07 02:29:22 EST
Still the same problems as with 5.7p1.
Comment 4 Mike C 2011-02-11 14:27:52 EST
Is there any way that others can run tests to try to help here - it would be really nice to have 5.8p1 for f15 and then backport if possible to f14 also?
Comment 5 Jan F. Chadima 2011-02-11 16:13:36 EST
the openssh-5.8p1 is considerably changed against the openssh-5.6p1 so to port the patches gets some time.
In addition to that I just found the bug in the upstream sources causing inability to compile these sources with selinux enabled.
Comment 6 Jan F. Chadima 2011-02-14 10:41:22 EST
The openssh 5.8p1 is in rawhide, test it please.
Comment 7 Mike C 2011-02-14 14:08:40 EST
I booted the livecd for F15 from Fedora nightly for 12th Feb 2011.

I pulled your builds (f16) from koji and installed them in the running f15 livecd, and then did a basic test of the ssh client and server. Making an ssh connection out of the test machine into another machine on the network was fine with no problems at all. Making an inbound connection into the test machine was also fine, so basic ssh functionality for the client and server works fine.

I also made internal connections from liveuser to liveuser@localhost, and also to root@localhost after setting up login passwords for both. Again this test worked fine.

I have not tried testing portforwarding, or using keys for login - I will report back when I have time to test that also unless someone else tests before I get a chance to do it.

Anyway so far so good and thank you for building the packages.
Comment 8 Mike C 2011-02-16 13:59:43 EST
With the current f15 nightly builds failing with a gdm problem I will wait till the nightlies can boot and login and then test again in a few days.