Bug 673209

Summary: AttributeError: 'NoneType' object has no attribute 'rfind'
Product: [Fedora] Fedora Reporter: andy york <soylentman>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: rawhideCC: anaconda-maint-list, bugs.michael, christian.joensson, jonathan, soylentman, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: anaconda_trace_hash:13e6ac725adbd0af05fa966a5b8f232b15094805c536c727763395407c8d2b0f
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-01-27 13:03:23 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda. none

Description andy york 2011-01-27 12:56:47 EST
The following was filed automatically by anaconda:
anaconda 15.18 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/posixpath.py", line 112, in basename
    i = p.rfind('/') + 1
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 794, in get_sysfs_path_by_name
    dev_name = os.path.basename(dev_name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 407, in majorminor
    sysfs_path = get_sysfs_path_by_name(device)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/lvmpv.py", line 153, in writeKS
    f.write("pv.%s" % self.majorminor)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 1174, in writeKS
    self.format.writeKS(f)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1185, in writeKS
    device.writeKS(f, preexisting=preexisting, noformat=noformat)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/__init__.py", line 379, in writeKS
    self.storage.writeKS(f)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 67, in writeKSConfiguration
    anaconda.writeKS(fn)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1265, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1286, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoneType' object has no attribute 'rfind'
Comment 1 andy york 2011-01-27 12:56:53 EST
Created attachment 475652 [details]
Attached traceback automatically from anaconda.
Comment 2 andy york 2011-01-27 12:57:35 EST
Created attachment 475654 [details]
Attached traceback automatically from anaconda.
Comment 3 Chris Lumens 2011-01-27 13:03:23 EST

*** This bug has been marked as a duplicate of bug 672603 ***
Comment 4 Michael Schwendt 2011-02-04 12:29:43 EST
Created attachment 477073 [details]
Attached traceback automatically from anaconda.
Comment 5 Christian Joensson 2011-02-05 15:39:03 EST
Created attachment 477237 [details]
Attached traceback automatically from anaconda.