Bug 6742

Summary: SEGFAULT in PyDict_New() while python script. No error after Python is compiled from SRPM
Product: [Retired] Red Hat Linux Reporter: pogosyan
Component: pythonAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-12-20 21:00:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description pogosyan 1999-11-05 02:46:55 UTC
I use FortyTwo.py script from
http://www.uni-karlsruhe.de/~Bjoern.Giesler/Download/FortyTwo.tar.gz

It worked find under RH5.2 but fails with segmentaion fault
in PyDict_New() after upgrade to RH6.0. This persists after
I upgraded to python-1.5.2-7 from RH6.1
GDB trace follows. What is interesting, the program works
fine if I download python-1.5.2-7.src.rpm and compile it
manually, enabling Tcl/Tk support

GDB output
myprompt> gdb /usr/bin/python
(gdb) run
>>> execfile("/usr/local/lib/FortyTwo/FortyTwo.py")
Traceback (innermost last):
  File "<stdin>", line 1, in ?
  File "/usr/local/lib/FortyTwo/FortyTwo.py", line 460, in ?
    from FWidgets import *
ImportError: No module named FWidgets
>>>

or analyzing the coreTraceback (innermost last):
prompt> gdb /usr/lib/python core
.....
Core was generated by
`python/usr/local/lib/FortyTwo/FortyTwo.py'
..............
#0  0x806fc42 in PyDict_New ()
(gdb)

Comment 1 Michael K. Johnson 1999-11-22 19:00:59 UTC
I have no vgetty settup, but I do have a question first: have you tried
using the gtk widget set instead of the tk widget set?

Comment 2 Nalin Dahyabhai 1999-12-20 21:00:59 UTC
Please see if this is fixed in python-1.5.2-9 or later from RawHide, and let me
know either way.

Comment 3 Brent Fox 2002-06-05 04:54:40 UTC
This is bound to have been fixed by now.