Bug 674552

Summary: ksh memory leak significantly slows the execution of shell scripts
Product: Red Hat Enterprise Linux 5 Reporter: RHEL Product and Program Management <pm-rhel>
Component: kshAssignee: Michal Hlavinka <mhlavink>
Status: CLOSED ERRATA QA Contact: BaseOS QE - Apps <qe-baseos-apps>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 5.5CC: bnater, bz-reply, cww, gbarros, jwest, kvolny, mhlavink, mpoole, ovasik, pm-eus, tao, tsmetana
Target Milestone: rcKeywords: Patch, ZStream
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Due to a memory leak in the ksh executable, the performance of long running scripts could decrease significantly over the time. With this update, the underlying source code has been modified to prevent this memory leak, and the execution of long running scripts is no longer slowed down.
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-28 04:52:01 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 586923    
Bug Blocks:    

Description RHEL Product and Program Management 2011-02-02 08:31:51 EST
This bug has been copied from bug #586923 and has been proposed
to be backported to 5.6 z-stream (EUS).
Comment 5 Jaromir Hradilek 2011-02-03 10:33:06 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to a memory leak in the ksh executable, the performance of long running scripts could decrease significantly over the time. With this update, the underlying source code has been modified to prevent this memory leak, and the execution of long running scripts is no longer slowed down.
Comment 6 Branislav NĂ¡ter 2011-02-23 05:36:45 EST
Bugfix was successfully verified on ksh-20100202-1.el5_6.3 package on all architectures (i386, ia64, ppc, s390x, x86-64). Loop time doesn't increase (see bellow) 

# rpm -q ksh
ksh-20100202-1.el5_6.3.i386

ksh version: Version AJM 93t+ 2010-02-02

    +-------------- pass number
    |            +- current loop time/1st loop time
    |            |  process size --------------------------------------+
    |            |  total time in seconds ----------------+            |
    |            |  current loop time +                   |            |
    |            |                    |                   |            |
   \ /          \ /                  \ /                 \ /          \ /
p#   1: cur/1st= 1.00; loop(secs)=  1.87; total(secs)=    1.87; RSS=0001444
p#   2: cur/1st= 1.00; loop(secs)=  1.86; total(secs)=    3.73; RSS=0001452
p#   3: cur/1st= 1.00; loop(secs)=  1.86; total(secs)=    5.59; RSS=0001452
p#   4: cur/1st= 1.01; loop(secs)=  1.89; total(secs)=    7.48; RSS=0001452
p#   5: cur/1st= 1.01; loop(secs)=  1.89; total(secs)=    9.37; RSS=0001452
p#   6: cur/1st= 1.01; loop(secs)=  1.89; total(secs)=   11.27; RSS=0001452
p#   7: cur/1st= 1.01; loop(secs)=  1.89; total(secs)=   13.16; RSS=0001452
p#   8: cur/1st= 1.01; loop(secs)=  1.89; total(secs)=   15.06; RSS=0001452
p#   9: cur/1st= 1.01; loop(secs)=  1.89; total(secs)=   16.95; RSS=0001452
p#  10: cur/1st= 1.01; loop(secs)=  1.89; total(secs)=   18.84; RSS=0001452
Comment 7 errata-xmlrpc 2011-02-28 04:52:01 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0304.html