Bug 675111

Summary: ssh-agent as user stops working
Product: [Fedora] Fedora Reporter: pascal kolijn <pascal>
Component: opensshAssignee: Jan F. Chadima <jchadima>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: rawhideCC: dmach, jchadima, mgrepl, tmraz
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-08 03:47:15 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description pascal kolijn 2011-02-04 06:00:07 EST
Description of problem:

After starting ssh-agent up as a user, it dies immediately.

Version-Release number of selected component (if applicable):
$ rpm -qf `which ssh-agent`
openssh-clients-5.6p1-28.fc15.i686

How reproducible:
Always

Steps to Reproduce:
1.

$ ssh-agent
SSH_AUTH_SOCK=/tmp/ssh-oZoUy11452/agent.11452; export SSH_AUTH_SOCK;
SSH_AGENT_PID=11453; export SSH_AGENT_PID;
echo Agent pid 11453;
$ SSH_AUTH_SOCK=/tmp/ssh-oZoUy11452/agent.11452; export SSH_AUTH_SOCK;
$ SSH_AGENT_PID=11453; export SSH_AGENT_PID;

$ env | grep -i ssh 
SSH_AGENT_PID=11453
SSH_AUTH_SOCK=/tmp/ssh-oZoUy11452/agent.11452
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass

2.
$ ssh-add -l
Could not open a connection to your authentication agent.

The directory /tmp/ssh-oZoUy11452/agent.11452 is not created.
in /var/log/messages:

ssh-agent[11453]: error: setrlimit RLIMIT_CORE: Operation not permitted

3.
  
Actual results:

no running ssh-agent

Expected results:

a running ssh-agent

Additional info:
Comment 1 Jan F. Chadima 2011-02-04 07:35:29 EST
this is reported as the kernel problem, please update to kernel-2.6.38-0.rc2.git7.1.fc15 and test again.
Comment 2 pascal kolijn 2011-02-04 09:22:24 EST
It took some time to get the suggested kernel to boot.. (rawhide already has a newer kernel which gave me an oops. the latest gdm did not allow me to change my session etc...

But I'm using it now it does not solve the problem...

$ uname -a
Linux nihal 2.6.38-0.rc2.git7.1.fc15.i686.PAE #1 SMP Sat Jan 29 18:29:15 UTC 2011 i686 i686 i386 GNU/Linux

I just noticed I'm using the PAE version... I will install the other one as well and try again...

$ env | grep -i ssh
SSH_AGENT_PID=3801
SSH_AUTH_SOCK=/tmp/ssh-PgZxpK3800/agent.3800
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass

and in the log:

Feb  4 15:11:34 nihal ssh-agent[3801]: error: setrlimit RLIMIT_CORE: Operation not permitted
Comment 3 Daniel Mach 2011-02-07 08:13:32 EST
It works for me with some RC3 kernel.
Not sure about exact version (my rawhide box is not online so I can't check it), probably this one:
kernel-2.6.38-0.rc3.git4.1.fc15
Comment 4 pascal kolijn 2011-02-08 03:46:20 EST
Yep ! with the following kernel (and it boots too :O) ) ssh-agent works again:

$ uname -a
Linux nihal 2.6.38-0.rc3.git4.1.fc15.i686.PAE #1 SMP Sat Feb 5 02:15:40 UTC 2011 i686 i686 i386 GNU/Linux