Bug 676946

Summary: virt-preview: windows guest fails with kvm_mutex_unlock: Assertion `!cpu_single_env' failed.
Product: [Fedora] Fedora Reporter: Julian Sikorski <belegdol>
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 14CC: amit.shah, berrange, dwmw2, ehabkost, gcosta, itamar, jaswinder, jforbes, jlmagee, knoel, markmc, ondrejj, psj, scottt.tw, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-04 16:55:29 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
libvirt log
domain config none

Description Julian Sikorski 2011-02-11 18:46:16 EST
Created attachment 478330 [details]
libvirt log

Description of problem:
after updating qemu today my windows guest using spice does not boot anymore. It dies with the following backtrace:

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7f4fe352e700 (LWP 9670)]
0x00000032d6a330c5 in raise () from /lib64/libc.so.6
(gdb) bt
#0  0x00000032d6a330c5 in raise () from /lib64/libc.so.6
#1  0x00000032d6a34a76 in abort () from /lib64/libc.so.6
#2  0x00000032d6a2b905 in __assert_fail () from /lib64/libc.so.6
#3  0x00000000004340c3 in kvm_mutex_unlock ()
    at /usr/src/debug/qemu-kvm-0.14.0/qemu-kvm.c:1724
#4  qemu_mutex_unlock_iothread ()
    at /usr/src/debug/qemu-kvm-0.14.0/qemu-kvm.c:1737
#5  0x00000000005de870 in qxl_hard_reset (d=0x2b80f00, loadvm=0)
    at /usr/src/debug/qemu-kvm-0.14.0/hw/qxl.c:665
#6  0x00000000005e02ff in ioport_write (opaque=0x2b80f00, 
    addr=<value optimized out>, val=0)
    at /usr/src/debug/qemu-kvm-0.14.0/hw/qxl.c:979
#7  0x0000000000431ebf in kvm_handle_io (env=0x2754e30)
    at /usr/src/debug/qemu-kvm-0.14.0/kvm-all.c:818
#8  kvm_run (env=0x2754e30) at /usr/src/debug/qemu-kvm-0.14.0/qemu-kvm.c:617
#9  0x00000000004333f9 in kvm_cpu_exec (env=<value optimized out>)
    at /usr/src/debug/qemu-kvm-0.14.0/qemu-kvm.c:1233
#10 0x0000000000433661 in kvm_main_loop_cpu (_env=0x2754e30)
    at /usr/src/debug/qemu-kvm-0.14.0/qemu-kvm.c:1419
#11 ap_main_loop (_env=0x2754e30)
    at /usr/src/debug/qemu-kvm-0.14.0/qemu-kvm.c:1466
#12 0x00000032d7206ccb in start_thread () from /lib64/libpthread.so.0
#13 0x00000032d6ae0c2d in clone () from /lib64/libc.so.6
(gdb) quit

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. enable virt-preview repo
2. update
3. try to boot the domain (I'll attach it later)
Actual results:
qemu dies

Expected results:
virtual machine boots
Comment 1 Julian Sikorski 2011-02-11 18:47:09 EST
Created attachment 478331 [details]
domain config
Comment 2 John L Magee 2011-02-12 12:03:07 EST
Same result with Windows VM that worked before qemu-kvm-0.14.0

In addition, core dump fails:
Feb 12 11:39:35 mnetjlm1 kernel: [ 2472.594524] kvm: 7417: cpu0 unhandled wrmsr: 0x198 data 0
Feb 12 11:39:35 mnetjlm1 kernel: [ 2472.595683] kvm: 7417: cpu1 unhandled wrmsr: 0x198 data 0
Feb 12 11:39:55 mnetjlm1 kernel: [ 2492.650460] CE: hpet increased min_delta_ns to 11250 nsec
Feb 12 11:40:04 mnetjlm1 abrt[7450]: saved core dump of pid 7417 (/usr/bin/qemu-kvm) to /var/spool/abrt/ccpp-1297528792-7417.new/coredump (1885470720 bytes)
Feb 12 11:40:04 mnetjlm1 abrtd: Directory 'ccpp-1297528792-7417' creation detected
Feb 12 11:40:04 mnetjlm1 abrtd: Package 'qemu-system-x86' isn't signed with proper key
Feb 12 11:40:04 mnetjlm1 abrtd: Corrupted or bad crash /var/spool/abrt/ccpp-1297528792-7417 (res:5), deleting
Comment 3 Paul Jenner 2011-03-04 15:01:21 EST
Duplicate of bug #681220 - qemu-kvm-0.14.0/qemu-kvm.c:1724: kvm_mutex_unlock: Assertion `!cpu_single_env' failed ?
Comment 4 Julian Sikorski 2011-03-04 16:55:29 EST

*** This bug has been marked as a duplicate of bug 681220 ***