Bug 677825

Summary: yelp Help Browser fails to start
Product: [Fedora] Fedora Reporter: xunilarodef
Component: yelpAssignee: Matthew Barnes <mbarnes>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 14CC: igor.katalnikov, mbarnes, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-05 01:32:53 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
screenshot of non-reproduction none

Description xunilarodef 2011-02-15 19:01:33 EST
Description of problem: The yelp Help Browser fails to open a window or display any help.

Version-Release number of selected component (if applicable):
yelp-2.30.2-1.fc14.i686

How reproducible:  Every time.

Steps to Reproduce:
1. System, Help (item with hover text of "Get help with GNOME"). 
2. Or, to gain a clue, start it from a terminal: 
 - - -
[u@who ~]$ yelp
Could not initialize gecko!
[u@who ~]$
 - - - 
3. In neither case does the help browser window open, potentially leaving a helpless user.
  
Actual results:
Attempts to start yelp from the System menu item may lead to an item on the bottom panel for a few seconds titled "Starting yelp", but no other visible result.  In neither case does the yelp window open.

Expected results:
The yelp browser window opens and displays the selected content.

Additional info:
Both Firefox 3.6 and the Firefox 4 beta (via the:
http://repos.fedorapeople.org/repos/spot/firefox4/fedora-...
repo) are installed.  The symptoms remain unchanged regardless of which Firefox is currently running, or even if neither Firefox is running.
 - - -
[u@who ~]$ rpm --query --whatprovides /usr/bin/firefox4
firefox4-4.0-0.13.b11.fc14.i686
[u@who ~]$ rpm --query --whatprovides /usr/bin/firefox
firefox-3.6.13-1.fc14.i686
[u@who ~]$
 - - -

/usr/lib/xulrunner-1.9.2/...
/usr/lib/xulrunner-2/...
are both present.

 yelp-main.c line circa 396 is:
 - - -
	if (!yelp_html_initialize ()) {
		g_printerr ("Could not initialize gecko!\n");
		exit (1);
	}
 - - -
Comment 1 Matěj Cepl 2011-02-22 20:42:35 EST
Created attachment 480310 [details]
screenshot of non-reproduction

Cannot reproduce here. My suspicion is that you have introduced some incompatibility (spot's repo is known to have tendency to corrupt things ... e.g., it used to introduce incompatible nss packages). For FF4betas I found it much more stable to use upstream binary from http://www.mozilla.com/en-US/firefox/all-beta.html. (it can be unpackaged in an arbitrary directory and run from there).

Please, disable spot's repo, downgrade all your packages to Fedora official versions (be careful around downgrading nss ... both yum and rpm depends on it), and then to reproduce, please.

Does it help?
Comment 2 xunilarodef 2011-03-07 19:14:14 EST
(In reply to comment #1)

[root@localhost ~]#  yum erase 'xulrunner2*'

is the crucial ingredient to restore System, Help (or yelp) to its expected behavior.  Of course, the simplest pre-requisite for this removal to succeed would be for one to have already similarly removed firefox4 (or to allow it to be erased as a dependent of the xulrunner2 package), but it seems the "upgraded" nss* packages firefox4 pulled in can remain without causing this symptom, at least.

So it seems fair to observe that this failure cannot be reproduced with pure Fedora 14 packages.
https://fedoraproject.org/wiki/Releases/15/FeatureList
does not hint at any intent to pull Firefox 4 into Fedora 15.  But this report may be a useful reminder to somebody for some future rawhide / Fedora 16 / ? version of Firefox, unless something in the implementation of yelp or xulrunner2 is re-engineered.  Is there a constructive way to tag this bug to reduce the costs of future re-discoveries?
Comment 3 Igor Katalnikov 2011-03-21 10:28:00 EDT
I would like to suggest following workaround which seems to solve a lot of problems:

1. Remove Firefox 3.6 (but not xulrunner).
2. Install Firefox 4/xulrunner2 and occasionally desired add-on's.
3. In "Preferred Applications" change "Default Web Browser" to "Custom" with corresponding Command: firefox4 "%s".

This restores yelp functionality and other www hyperlinks across Gnome.
Comment 4 Matěj Cepl 2011-04-05 01:32:53 EDT
(In reply to comment #2)

> https://fedoraproject.org/wiki/Releases/15/FeatureList
> does not hint at any intent to pull Firefox 4 into Fedora 15.

Of course, Fedora 15 contains FF4. Heck, that’s what I am using right now (firefox-4.0-2.fc15.x86_64)!

However, really this is a problem with spot's repo. Closing as NOTABUG. If Mr. Katalnikov’s workaround works, even better.