Bug 678789

Summary: gpxe virtio-net driver incorrectly hardcodes frame length always as 1514
Product: [Fedora] Fedora Reporter: Charles R. Anderson <cra>
Component: gpxeAssignee: Matt Domsch <matt_domsch>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 13CC: bloch, gcosta, jforbes, lfarkas, matt_domsch
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: gpxe-1.0.1-4.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 679188 (view as bug list) Environment:
Last Closed: 2011-03-01 20:51:56 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 679188    
Attachments:
Description Flags
virtio-net: set size of transmitted ethernet frame to header + data length none

Description Charles R. Anderson 2011-02-19 12:21:22 EST
Created attachment 479710 [details]
virtio-net: set size of transmitted ethernet frame to header + data length

Description of problem:

All ethernet frames sent by gpxe's virtio-net driver have a length of 1514, regardless of the actual size needed to encapsulate the data.  This messes up at least DHCP on some networks, because the DHCP relay agent can't manipulate the "full" ethernet frame.  This was causing KVM PXE failures for me since the DHCP transaction wouldn't complete.

Version-Release number of selected component (if applicable):
gpxe-1.0.1-1

How reproducible:
always

Steps to Reproduce:
1. Use virt-manager to create a VM with network driver virtio
2. Try to PXE boot the VM
3. Monitor the traffic--all frames have an ethernet length of 1514
  
Actual results:
fail to boot via PXE

Expected results:
Should boot via PXE.  virtio-net should set the ethernet frame length to the actual size of the data to be sent + headers.

Additional info:
See attached patch for the fix.
Comment 1 Charles R. Anderson 2011-02-19 12:29:03 EST
Same fix needs to be applied to F13, F14, F15, rawhide/F16, and EL5 branches.  Thanks.
Comment 2 Levente Farkas 2011-02-20 15:05:37 EST
what's up with el6?
Comment 3 Charles R. Anderson 2011-02-21 11:58:13 EST
Same bug exists in el6.  Could someone who has a RHEL subscription please open a ticket?  Thanks.
Comment 4 Matt Domsch 2011-02-21 15:31:17 EST
EL6 bug #679188

Thanks for the patch Chuck.  Applied on F13-rawhide and EL5 branches now.  Gonna need some testing.
Comment 5 Fedora Update System 2011-02-21 15:45:25 EST
gpxe-1.0.1-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/gpxe-1.0.1-3.el5
Comment 6 Fedora Update System 2011-02-21 15:46:10 EST
gpxe-1.0.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gpxe-1.0.1-3.fc14
Comment 7 Fedora Update System 2011-02-21 15:46:38 EST
gpxe-1.0.1-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gpxe-1.0.1-3.fc13
Comment 8 Fedora Update System 2011-02-21 23:37:50 EST
gpxe-1.0.1-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gpxe-1.0.1-4.fc15
Comment 9 Fedora Update System 2011-02-21 23:53:23 EST
gpxe-1.0.1-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gpxe'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gpxe-1.0.1-3.fc13
Comment 10 Fedora Update System 2011-03-01 20:51:51 EST
gpxe-1.0.1-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-03-01 20:52:28 EST
gpxe-1.0.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2011-03-02 22:39:53 EST
gpxe-1.0.1-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.