Bug 679807

Summary: Keyboard unusable in runlevel 5 mode.
Product: [Fedora] Fedora Reporter: H. <dbkblk>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-01 04:33:59 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Useful files for debugging none

Description H. 2011-02-23 09:40:55 EST
Created attachment 480477 [details]
Useful files for debugging

Description of problem: 
I tried fedora testday to report radeon drivers problems today and everything was fine with the liveCD. So i decided to install it to a partition to test it from time to time. GRUB is still managed by my Debian testing setup.

I rebooted into fedora and came to gdm3. I can perfectly use my mouse or touchpad but the keyboard is PARTIALLY unresponsive.
All the ASUS key work (tune up / down the wolume / brightness) and the printscreen key work. However, all others keys does not work (i cannot enter, go to console CTRL+ALT+F1, anything other did not worked).

I've tried to boot into runlevel3 thanks to grub and my keyboard perfectly worked in console mode. As soon as i type "telinit 5", i go to gdm and cannot use my keyboard anymore (nor get back to the virtual terminal :(). Everything worked as intended with the LiveCD !

I saw this behavior with Ubuntu Natty last week (but i haven't reported) which share the same kernel as F15. So i suspect it.

Version-Release number of selected component (if applicable):
Kernel 2.6.38

How reproducible:
I think you need my laptop for that :D

Actual results:
The distribution is unusable as i cannot login, nor do anything graphical !

Expected results:
To have a working keyboard, like it did into my Debian (with 2.6.37)

Additional info:
Thanks to the #fedora-test-day chan, ive gathered some infos that you could need.
I used "gfx_test_week_20110221_x86-64" to install and updated it trough console mode @ approx 13h30 GMT.
Comment 1 H. 2011-02-24 02:25:10 EST
I forgot to add some basic informations about my laptop:
http://www.smolts.org/client/show/pub_988a55ec-924e-42fa-9f5a-5b9387e84ac8
Comment 2 H. 2011-03-01 04:33:59 EST
I updated with yum today and the bug is gone. I can use my keyboard on the gdm login.
Even if i can't open my session after the logon, because it keep doing nothing, i consider this bug fixed.

Thanks,