Bug 680169

Summary: Unable to fix label of /dev/.udev/watch/[1-30] No such file or directory
Product: [Fedora] Fedora Reporter: Jóhann B. Guðmundsson <johannbg>
Component: systemdAssignee: Lennart Poettering <lpoetter>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dwalsh, lpoetter, metherid, mgrepl, mschmidt, notting, plautrba
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-25 00:51:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jóhann B. Guðmundsson 2011-02-24 14:24:34 UTC
Description of problem:

Fresh install of Fedora alpha rc1 i386

Unable to fix label of /dev/.udev/watch/1 ( up to 30 ) No such file or directory

Version-Release number of selected component (if applicable):

selinux-policy-3.9.15-2.fc15.noarch

How reproducible:

Always

Steps to Reproduce:
1. Boot press esc 
2. watch error
3.
  
Actual results:

The above error

Expected results:

No error

Additional info:

systemd-readahe avc denials though to be fixed are present on rc1 see closed bug 676617

Comment 1 Daniel Walsh 2011-02-24 18:11:08 UTC
What are the AVC's and why are you opening a new bug?

Comment 2 Jóhann B. Guðmundsson 2011-02-24 18:18:51 UTC
No AVC present this happens in earlies stages @ boot up since it does not make down with dmesg so much be something dracut related 

What new bug are you referring to I commented the systemd-readahe stuff on the old one and opened a new one for this message? ( two seperated issues )

Comment 3 Daniel Walsh 2011-02-24 18:24:35 UTC
Well not sure this is an SELinux issue, but a systemd one.  The comment through me off.

This looks like systemd-readahead tried to create a labeled file on a file that does not exist and reports and error.

Comment 4 Lennart Poettering 2011-02-24 22:29:55 UTC
Johann, which process is logging this? is that systemd itself, or systemd-readahead? can you somehow get me the precise error emssages?

Comment 5 Lennart Poettering 2011-02-25 00:51:10 UTC
Under the assumption that this is PID1 i think I have now fixed this. My guess is that the dead symlinks udev maintains in /dev were the source of the problem. systemd git now ignores ENOENT when iterating through /dev and relabelling. We should do that anyway to fix a race when /dev gets modified while we iterate through it and a file doesn't exist anymore when we try to relabel it although it was still there when we enumerated it.