Bug 680351

Summary: ypbind checks for fastest server every minute (should be 15 minutes)
Product: Red Hat Enterprise Linux 4 Reporter: Masahiro Matsuya <mmatsuya>
Component: ypbindAssignee: Karel Klíč <kklic>
Status: CLOSED DUPLICATE QA Contact: qe-baseos-daemons
Severity: high Docs Contact:
Priority: high    
Version: 4.8CC: rvokal
Target Milestone: rcKeywords: Regression
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-25 08:32:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Masahiro Matsuya 2011-02-25 08:28:05 UTC
Description of problem:
ypbind will check to see if the current NIS server is the fastest every 1 minite.
But, manpage of ypbind says it's 15 minites.

This occurred with a fix of https://bugzilla.redhat.com/show_bug.cgi?id=198689.
The fix includes this part:

@@ -1024,7 +1049,8 @@ test_bindings (void *param __attribute__
 	pthread_exit (&success);
 
       lastcheck += ping_interval;
-      if (lastcheck >= 900) /* 900 = 15min. */
+      //if (lastcheck >= 900) /* 900 = 15min. */
+      if (lastcheck >= 60) /* 900 = 15min. */
 	lastcheck = 0;
 
       lastcheck = test_bindings_once(lastcheck);

So, it was changed into 60 second (1min) clearly here. But, I cannot see why this change is needed for the fix of BZ198689. 

The fix on BZ198689 was introduced from rhel4.5. So, this can be a regression from rhel4.4 or before.

Version-Release number of selected component (if applicable):
ypbind-1.17.2-13 and later

How reproducible:
Always

Steps to Reproduce:
1. run ypbind 
2. check the interval of "Pinging all active server" message
  
Actual results:
ypbind checks it every 1 min

Expected results:
ypbind checks it every 15 min

Additional info:

RHEL5 has this same change, which means the same bug.
RHEL6 doesn't have this change.

Comment 2 Masahiro Matsuya 2011-02-25 08:32:13 UTC
This is duplicate of BZ594670. Sorry for noise.

*** This bug has been marked as a duplicate of bug 594670 ***