Bug 680746

Summary: vt switching does not work
Product: [Fedora] Fedora Reporter: Jaroslaw Gorny <jaroslaw.gorny>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: airlied, ajax, bskeggs, robatino
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-03 00:28:23 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Jaroslaw Gorny 2011-02-27 08:16:01 EST
Description of problem:
Test QA:Testcase_nouveau_vt fails.
https://fedoraproject.org/wiki/QA:Testcase_nouveau_vt

Version-Release number of selected component (if applicable):
Alpha F15 Live CD: gfx_test_week_20110221_x86-64.iso

How reproducible:
Always

Steps to Reproduce:
1. Press Alt+Ctrl+F2
2. Login into the console as root
3. Press Alt+F1
  
Actual results:
Scrambled output (mostly textmode characters) is displayed.

Expected results:
X Session running on VT1 should be visible.

Additional info:
Smolt: http://www.smolts.org/client/show/pub_7ac3b9ad-6c68-4bfa-b514-33cf9a4dd8f3
Comment 1 Andre Robatino 2011-02-27 13:15:00 EST
Check VT7 instead. There's an old bug (bug 503267) where if the X server gets restarted, it ends up on VT7 instead of VT1. If you had the other problem where you had to log out and back in to get gnome shell instead of fallback, that's enough to trigger this.
Comment 2 Jaroslaw Gorny 2011-02-27 14:21:16 EST
@Andre: ah, thanks, I will check this. Anyways, the bug report is still valid - X Server should not crash at all while switching VTs :)
Comment 3 Jaroslaw Gorny 2011-02-28 16:39:23 EST
I'm confused. I've tried Alpha CD today again, and VT switching worked flawlessly. I switched between VT1 and VT2 several times. On X Server there was couple of apps running (including Firefox with html5 video turned on).

I guess my initial crashes were results of some other "gfx test day" tests I did on this system.
Please let me check this once again tomorrow. If switching is successfull again, we should close this, 'cause looks like I cannot reproduce this behaviour.
Thanks!
Comment 4 Jaroslaw Gorny 2011-03-02 06:53:02 EST
I tried it today on a freshly started system, without external monitor. And I was not able to reproduce this any more.
So I believe the reason why this test failed before was because of some other test that I've performed and which failed.
I think we should close this bug then.
Thanks!
Comment 5 Ben Skeggs 2011-03-03 00:28:23 EST
Ok, thank you.  Please reopen if you have further issues with this!