This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 683481

Summary: Rebase to systemtap 1.6 for rhel5.8
Product: Red Hat Enterprise Linux 5 Reporter: Frank Ch. Eigler <fche>
Component: systemtapAssignee: Frank Ch. Eigler <fche>
Status: CLOSED ERRATA QA Contact: qe-baseos-tools
Severity: high Docs Contact:
Priority: high    
Version: 5.8CC: mjw, mprpic, pmuller, wcohen
Target Milestone: rcKeywords: Rebase, Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: systemtap-1.6-4.el5 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Maybe something like the following for rhel 5.8 release notes: SystemTap SystemTap is a tracing and probing tool that allows users to study and monitor the activities of the operating system (particularly, the kernel) in fine detail. It provides information similar to the output of tools like netstat, ps, top, and iostat; however, SystemTap is designed to provide more filtering and analysis options for collected information. SystemTap in Red Hat Enterprise Linux 5.8 is updated to version 1.6, providing: * Handle kernel modules with "-" in name such as "i2c-core" properly * The process.mark() function now supports $$parms for reading probe parameters. * The operation of the compile-server and client was improved and simplified: -The compile server can cache the scripts build results. -The compile server and client communicate exchange version info to adjust communication protocol and use newest version of server. -The following deprecated tools were removed: stap-client, stap-authorize-server-cert, stap-authorize-signing-cert, stap-find-or-start-server, and stap-find-servers. * For remote execution, the "--remote USER@HOST" functionality can now be specified multiple times and will automatically build the script for distinct kernel and architecture configurations, and run it on all named machines at once. * The staprun program allows multiple instance of the same script to run at same time. * Added tz_ctime() function prints time in local time zone. * Added HZ() and jiffies() functions for lightweight approximate time keeping.
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-21 00:44:42 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Frank Ch. Eigler 2011-03-09 09:28:23 EST
systemtap 1.4 is already available, and 1.5 is likely by early 5.7 deadlines.
Let's consider rebasing as usual.
Comment 4 RHEL Product and Program Management 2011-04-05 10:34:47 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 5 Frank Ch. Eigler 2011-08-14 20:41:58 EDT
Let's consider again for RHEL5.8.
We have a release 1.6 in RHEL6.2, which has already been tested on RHEL5.7+,
Comment 10 William Cohen 2012-01-18 11:18:09 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Maybe something like the following for rhel 5.8 release notes:

SystemTap

SystemTap is a tracing and probing tool that allows users to study and
monitor the activities of the operating system (particularly, the
kernel) in fine detail. It provides information similar to the output
of tools like netstat, ps, top, and iostat; however, SystemTap is
designed to provide more filtering and analysis options for collected
information.  SystemTap in Red Hat Enterprise Linux 5.8 is updated to
version 1.6, providing:

   * Handle kernel modules with "-" in name such as "i2c-core" properly
   * The process.mark() function now supports $$parms for reading probe parameters.
   * The operation of the compile-server and client was improved and simplified:
     -The compile server can cache the scripts build results.
     -The compile server and client communicate exchange version info to
      adjust communication protocol and use newest version of server.
     -The following deprecated tools were removed: stap-client,
      stap-authorize-server-cert, stap-authorize-signing-cert,
      stap-find-or-start-server, and stap-find-servers.
   * For remote execution, the "--remote USER@HOST" functionality can now 
     be specified multiple times and will automatically build the script
     for distinct kernel and architecture configurations, and run it on
     all named machines at once.
   * The staprun program allows multiple instance of the same script to run at same time.
   * Added tz_ctime() function prints time in local time zone.
   * Added HZ() and jiffies() functions for lightweight approximate time keeping.
Comment 13 errata-xmlrpc 2012-02-21 00:44:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0200.html