Bug 683832

Summary: Selinux AVC for systemd-tmpfile during boot
Product: [Fedora] Fedora Reporter: Bruno Wolff III <bruno>
Component: selinux-policyAssignee: Miroslav Grepl <mgrepl>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: bruno, dwalsh, johannbg, lpoetter, metherid, mgrepl, mschmidt, notting, plautrba
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: selinux-policy-3.9.16-5.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-19 05:53:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bruno Wolff III 2011-03-10 13:14:28 UTC
Description of problem:
I get the following AVC during boot (shows up in dmesg output):
[  100.659311] type=1400 audit(1299761605.280:6): avc:  denied  { read } for  pid=1197 comm="systemd-tmpfile" name="rpm" dev=dm-1 ino=107542 scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=system_u:object_r:rpm_var_lib_t:s0 tclass=dir

Version-Release number of selected component (if applicable):
systemd-20-1.fc15.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Lennart Poettering 2011-03-11 23:54:57 UTC
This is caused by rpm's /etc/tmpfiles.d/rpm.conf file, which is used to remove /var/lib/rpm/__db.* on boot.

Comment 2 Miroslav Grepl 2011-03-14 08:40:38 UTC
Should be fix in the latest selinux-policy.

selinux-policy-3.9.16-3.fc15

Comment 3 Fedora Update System 2011-03-17 15:28:24 UTC
selinux-policy-3.9.16-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-5.fc15

Comment 4 Fedora Update System 2011-03-19 05:52:49 UTC
selinux-policy-3.9.16-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.