Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.

Bug 68439

Summary: can't get chooser from remote X terminal (gdmchooser crashes)
Product: [Retired] Red Hat Public Beta Reporter: Pavel <pavelr>
Component: gdmAssignee: Havoc Pennington <hp>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: limboCC: wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2002-07-15 16:44:44 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 67218    
Attachments:
Description Flags
syslog messages of failure (gdm debug output enabled)
none
gdmchooser error output none

Description Pavel 2002-07-10 04:32:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020709

Description of problem:
When I'm trying to connect with remote X terminal using indirect connection and
using gdm as display manager, I don't get a chooser and X just restarts. Query
connection works fine. When I run gdmchooser from command line it crashes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enable XDMCP for gdm and restart it.
2. Connect from other computer using "X -indirect <IP address/hostname> :<display>"

OR 
run gdmchooser from terminal

Actual Results:  X server restarts

OR 
gdmchooser crashes

Expected Results:  Get chooser window

Additional info:
Comment 1 Pavel 2002-07-10 04:33:38 EDT
Created attachment 64564 [details]
syslog messages of failure (gdm debug output enabled)
Comment 2 Pavel 2002-07-10 04:34:34 EDT
Created attachment 64565 [details]
gdmchooser error output
Comment 3 Havoc Pennington 2002-07-14 23:29:41 EDT
http://bugzilla.gnome.org/show_bug.cgi?id=88180

What is the remote terminal? (another linux machine, a real hardware X
terminal... ?)
Comment 4 Pavel 2002-07-15 02:45:31 EDT
I'm using XFree86 for cygwin on Win2k, but I also tried to connect from another
linux machine (running RedHat 7.3 with XFree 4.2.0) and StarNet X-Win32. All
give same result.
Comment 5 George Lebl 2002-07-15 16:44:40 EDT
This should be fixed in 2.4.0.1 if I remember correctly.  Several more related
bugs are fixed in CVS and so I'll make a 2.4.0.2 very very soon.
Comment 6 Elliot Lee 2002-08-26 13:34:10 EDT
Works now, I'll assume it was fixed.