Bug 684400

Summary: preupgrade fails after booting for upgrade
Product: [Fedora] Fedora Reporter: cam <camilo>
Component: preupgradeAssignee: Richard Hughes <richard>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 14CC: alejandro_liu, alkana54, andreas.petzold, jlaska, jonas.th, marbolangos, mattia.verga, rhughes
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: preupgrade-1.1.9-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-05-16 08:52:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
grub.conf
none
ks.cfg none

Description cam 2011-03-12 04:56:39 EST
Description of problem:
I installed preupgrade in F14, then yum update --enablerepo=updates-testing preupgrade (it didn't get any newer version)
After downloading all the packages and creating the metadata it allowed me to reboot. I did and found two problems.
- there was an unreasonably long delay with black screen and flashing cursor at boot time (1min?)
- when Anaconda ran it gave up immediately:
No method given for cmdline mode, aborting
install exited abnormally [1/1]
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.preupgrade
2.reboot
3.
  
Actual results:
Error message as above

Expected results:
Normal preupgrade

Additional info:
I know other people are having trouble with install from Live CD but I wanted to raise this to track the issue so I know when I can re-test.
Comment 1 Mattia Verga 2011-03-13 09:42:41 EDT
Same here.
F14 x86_64 -> F15Alpha

preupgrade.noarch                      1.1.8-1.fc14
Comment 2 Alejandro Liu 2011-03-15 06:24:31 EDT
Created attachment 484428 [details]
grub.conf

This is the grub.conf configuration file that preupgrade generated for me.
Comment 3 Alejandro Liu 2011-03-15 06:26:17 EDT
Created attachment 484429 [details]
ks.cfg

Kickstart file generated by pre-upgrade
Comment 4 Andreas Petzold 2011-03-15 13:23:04 EDT
I have the same problem with preupgrade from F14 to F15alpha i386. The ks.cfg and grub.conf look the same as the ones Alejandro posted above.
Comment 5 Jonas Thiem 2011-03-16 07:54:02 EDT
I got exactly the same problem here. 1 minute of blinking cursor hang, then the error specified above. After an additional reboot, the old unupgraded F14 starts as usual.

Don't know if it is relevant, but my partitions are all encrypted.
Comment 6 cam 2011-03-16 08:05:22 EDT
Note to potential testers, there may be a test day scheduled for this (tomorrow):

https://fedorahosted.org/fedora-qa/ticket/161

http://fedoraproject.org/wiki/QA/Fedora_15_test_days

https://fedoraproject.org/wiki/Test_Day:2011-03-17_Preupgrade (note draft page!)

It's not certain if the software is ready yet.
Comment 7 James Laska 2011-03-17 08:32:58 EDT
Greetings, can you please retest with the latest version of preupgrade-1.1.9-1?  You can find links at the Test Day page - https://fedoraproject.org/wiki/Test_Day:Current#Prerequisite_for_Test_Day
Comment 8 James Laska 2011-03-17 09:13:25 EDT
NOTE: the reason the installer is forcing you into command-line mode, is due to bug#678095
Comment 9 Mattia Verga 2011-03-17 14:01:22 EDT
Tried with preupgrade.noarch 1.1.9-1.fc14, the error became "No way to determine wich NIC to use".
You can see screenshots of the various consoles in http://www.coolbits.it/img/1.JPG http://www.coolbits.it/img/2.JPG and http://www.coolbits.it/img/3.JPG

As suggested by James Laska I have appended "updates=http://jlaska.fedorapeople.org/updates/f15-alpha.img" to the kernel line of preupgrade at startup, but the result is the same: anaconda is booted in command-line mode and gives the same error.

However I saw that "f15-alpha.img" is 99 Bytes! Is that correct??
Comment 10 cam 2011-03-17 18:10:40 EDT
(In reply to comment #7)
> Greetings, can you please retest with the latest version of preupgrade-1.1.9-1?
>  You can find links at the Test Day page -
> https://fedoraproject.org/wiki/Test_Day:Current#Prerequisite_for_Test_Day

Thanks, I tried the new preupgrade, it didn't work for me.

At first there was a dependency issue,

Package tuple ('libxml++', 'i686', '0', '2.33.2', '1.fc14') could not be found in rpmdb

I used yum erase to remove that and tried again, when I hit 684742 - I see others have had the same problem on the test day wiki page. I took a screenshot if it helps.

I also noticed I was offered two network interfaces to complete the upgrade, one was wireless and did not give me any option to enter ssid or passphrase (so wasn't able to get a working link). Only the wired interface would work.
Comment 11 James Laska 2011-03-18 07:42:24 EDT
(In reply to comment #10)
> I also noticed I was offered two network interfaces to complete the upgrade,
> one was wireless and did not give me any option to enter ssid or passphrase (so
> wasn't able to get a working link). Only the wired interface would work.

Thanks for the feedback.  The issue with not offering SSID/passphrase options for your wireless device is a different issue.  Can you please file that against anaconda?  For that issue, any screenshots, and steps-to-reproduce would be very appreciated.
Comment 12 cam 2011-03-18 16:13:37 EDT
(In reply to comment #11)
> Thanks for the feedback.  The issue with not offering SSID/passphrase options
> for your wireless device is a different issue.  Can you please file that
> against anaconda?  For that issue, any screenshots, and steps-to-reproduce
> would be very appreciated.

Thanks for the comment, I have raised that as:

https://bugzilla.redhat.com/show_bug.cgi?id=689018
Comment 13 Mattia Verga 2011-03-27 12:33:14 EDT
Tested today and the upgrade went fine.
Comment 14 Stefan Becker 2011-03-29 22:52:09 EDT
Bodhi still doesn't show preupgrade-1.1.9. Can you please trigger the push?
Comment 15 Stefan Becker 2011-03-30 01:06:49 EDT
James: would it also be possible to update your f15-alpha.img to the latest anaconda 15.26? 15.25 doesn't seem to work with encrypted disks (in my case: LVM on encrypted PV, preupgrade repo on LV).
Comment 16 Stefan Becker 2011-05-15 03:04:36 EDT
I have now pre-upgraded two systems with encrypted disks from F14 to F15 Beta. No problems. I think this can be closed.
Comment 17 James Laska 2011-05-16 08:52:41 EDT
(In reply to comment #16)
> I have now pre-upgraded two systems with encrypted disks from F14 to F15 Beta.
> No problems. I think this can be closed.

Agreed!  Thanks for the feedback Stefan :)