Bug 684580

Summary: 'X' and '/' strike-through extends past affected range
Product: [Fedora] Fedora Reporter: dlelliott99
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: rawhideCC: caolanm, dledford, dtardon, fenlason, ltinkl
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: libreoffice-3.3.2.2-5.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-05 17:41:37 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description dlelliott99 2011-03-13 11:50:53 EDT
Description of problem:
1. Punctuation position: Position of comma in the Liberation Serif font is incorrect. This is especially noticable in the italicized possessive case.
2. When the / is used for an overstrike especially on a single letter, two or three extra slashes show up. It would also be very nice if other symbols could be used for an overstrike such as the: ~. In the URW Bookman L font this would be especially helpful for then you could have the letters er overstruck with ~.
3. A general comment: For a 160 GB hard drive, why could not the entire 160 GB be used rather than just 152 GB? I have tried Ubuntu and they are able to do this. There are probably reasons for this that I don't know about.

Version-Release number of selected component (if applicable):
All versions insofar as I know.

How reproducible:
Very

Steps to Reproduce:
1.Just try the above for a single letter with the slash overstrike.
2.
3.
  
Actual results:
You will see.


Expected results:


Additional info:
Comment 1 Jay Fenlason 2011-03-14 13:55:16 EDT
Openmpi has nothing to do with openoffice.  I think you opened this bug against the wrong component.  What component did you mean to open this bug against?
Comment 2 Doug Ledford 2011-03-25 14:47:25 EDT
This sounds like an openoffice issue to me.  Reassigning component.
Comment 3 Caolan McNamara 2011-03-25 17:01:19 EDT
Specific exact bug reports on one topic with reproducers, example test-cases and screenshots of the error please if necessary, help us help you by providing as much relevant clear supplementary information.

e.g. "Position of comma in the Liberation Serif font is incorrect. This is especially noticable in the italicized possessive case."

Provide a test document, and maybe a screenshot of the problem. Is the positioning different in e.g. gedit. i.e. are we talking about some bad OOo-specific layout or is font itself.
Comment 4 dlelliott99 2011-03-25 21:27:17 EDT
This shows the problem with an overstrike for one letter using the slash in the Liberation Serif font:

  a

There should only be one slash.

For three letters:

  one

There is an extra slash at the end.

Unfortunately, the copy did not carry over into this comment.

For the comma in the possessive case, see this example for the Liberation Serif font:

	their’s

Here, once more this comment area does not show the problem. Please try this in OpenOffice.org using the autocorrect option to replace the usual ' character with the custom character. This is especially noticable in the italicized Liberation Serif font.
Comment 5 dlelliott99 2011-03-25 21:35:21 EDT
Sorry, appended is a screenshot that you requested.

/home/dolphin/Desktop/Screenshot.png

I hope this works.

The problem seems to be in the font itself, i.e., in the position the apostrophe is in between letters.
Comment 6 Caolan McNamara 2011-03-28 11:04:08 EDT
There were no attachments to this issue. I can guess that / strike-through problem, those I don't see the problem with ’
Comment 7 Caolan McNamara 2011-03-29 08:59:25 EDT
So, I'll take this issue for fix the strike-through extending outside the range it is supposed to affect.
Comment 8 Fedora Update System 2011-03-30 15:02:50 EDT
libreoffice-3.3.2.2-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libreoffice-3.3.2.2-4.fc15
Comment 9 Fedora Update System 2011-03-30 23:56:59 EDT
Package libreoffice-3.3.2.2-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.3.2.2-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/libreoffice-3.3.2.2-4.fc15
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-03-31 11:31:05 EDT
libreoffice-3.3.2.2-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libreoffice-3.3.2.2-5.fc15
Comment 11 Fedora Update System 2011-04-05 17:41:27 EDT
libreoffice-3.3.2.2-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.