Bug 684849

Summary: newwin regression
Product: [Fedora] Fedora Reporter: Jaroslav ┼ákarvada <jskarvad>
Component: ncursesAssignee: Miroslav Lichvar <mlichvar>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: dickey, mlichvar
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ncurses-5.8-2.20110319.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-31 20:11:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 684854    
Attachments:
Description Flags
Proposed fix none

Description Jaroslav Škarvada 2011-03-14 16:24:55 UTC
Created attachment 484246 [details]
Proposed fix

Description of problem:
The newwin(0,0,0,0) doesn't work, but it should according to man page:
> A new full-screen window is created by calling newwin(0,0,0,0)

Version-Release number of selected component (if applicable):
ncurses-5.8-1.fc15.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install powertop
2. powertop
  
Actual results:
There is no tab-bar.

Expected results:
There should be tab-bar.

Additional info:
Apparently this is a regression because the code for auto-detection of window size is still there, but by-passed.

Comment 1 Thomas E. Dickey 2011-03-21 21:16:30 UTC
See

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=616711

I'm considering a 5.9 with this fix, plus the post-5.8
fixes for the Ada95 binding.

Comment 2 Fedora Update System 2011-03-22 15:28:32 UTC
ncurses-5.8-2.20110319.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ncurses-5.8-2.20110319.fc15

Comment 3 Fedora Update System 2011-03-31 20:11:13 UTC
ncurses-5.8-2.20110319.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.