Bug 686199

Summary: Fix FTBFS on PPC due to missing readq/writeq
Product: [Fedora] Fedora Reporter: Peter Lemenkov <lemenkov>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: gansalmon, itamar, jonathan, jwboyer, kernel-maint, kmcmartin, madhu.chinakonda
Target Milestone: ---   
Target Release: ---   
Hardware: ppc   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-30 00:04:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Patch which fixes this issue none

Description Peter Lemenkov 2011-03-15 14:14:06 UTC
Kernel 2.6.38 fails to build on PowerPC due to calls to missing readq/writeq in drivers/scsi/qla4xxx/ql4_nx.c. See the following buildlogs for the details:

* http://ppc.koji.fedoraproject.org/koji/getfile?taskID=157534&name=build.log

* http://ppc.koji.fedoraproject.org/koji/getfile?taskID=166261&name=build.log

This was also spotted (and fixed) by folks from Debian:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=598503

Comment 1 Peter Lemenkov 2011-03-15 14:15:20 UTC
Created attachment 484778 [details]
Patch which fixes this issue

Comment 2 Peter Lemenkov 2011-03-16 15:57:28 UTC
Koji scratchbuild for F-15 (ppc & ppc64):

http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=166326

Comment 3 Chuck Ebbert 2011-03-24 17:20:17 UTC
(In reply to comment #1)
> Created attachment 484778 [details]
> Patch which fixes this issue

Is this the correct fix (i.e. is this going upstream?) Shouldn't readq be added somewhere in the PPC arch definitions?

Comment 4 Peter Lemenkov 2011-03-24 17:30:35 UTC
(In reply to comment #3)
> (In reply to comment #1)
> > Created attachment 484778 [details]
> > Patch which fixes this issue
> 
> Is this the correct fix (i.e. is this going upstream?) Shouldn't readq be added
> somewhere in the PPC arch definitions?

Hello!

Unfortunately after some consideration I must admit that this is not a proper fix. It does mainly based on another one patch, but that is no excuse - to provide ugly patch because there is another ugly patch already applied.

I'll try to provide proper fix soon.

Comment 5 Kyle McMartin 2011-03-28 19:12:23 UTC
I think the correct fix is to simply disable the driver on 32-bit. A non-atomic 64-bit read can be a dangerous thing (think about a register whose value may change between reads.)

Comment 6 Josh Boyer 2011-03-29 13:10:56 UTC
(In reply to comment #5)
> I think the correct fix is to simply disable the driver on 32-bit. A non-atomic
> 64-bit read can be a dangerous thing (think about a register whose value may
> change between reads.)

Yes, agreed.  Kyle pointed out that the driver now requests firmware flash updates using those functions, and we aren't going to be able to support that on ppc32.  My previous "fix" I submitted to work around the build failure won't actually result in a fully working driver on this platform.  The likelihood of this functioning on those machines is pretty small at this point anyway.

Comment 7 Kyle McMartin 2011-03-30 00:04:13 UTC
OK, I've disabled this driver in the next build for F-15 and in git master for F-16 and beyond.

Comment 8 Fedora Update System 2011-03-30 18:14:20 UTC
kernel-2.6.38.2-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.2-9.fc15

Comment 9 Fedora Update System 2011-04-02 06:00:59 UTC
kernel-2.6.38.2-9.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.