Bug 687862

Summary: sample config file differs from documentation
Product: [Fedora] Fedora Reporter: Marcus Moeller <marcus.moeller>
Component: sssdAssignee: Stephen Gallagher <sgallagh>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dpal, jhrozek, sbose, sgallagh, ssorce
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-17 11:18:08 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Marcus Moeller 2011-03-15 11:39:04 EDT
from man sssd-ldap  

ldap_user_uid_number (string)
 The LDAP attribute that corresponds to the user´s id.

 Default: uidNumber

ldap_user_gid_number (string)
 The LDAP attribute that corresponds to the user´s primary group id.

 Default: gidNumber

This differs from the values in the example config file:

# ldap_user_uid_number = msSFU30UidNumber
# ldap_user_gid_number = msSFU30GidNumber
Comment 1 Dmitri Pal 2011-03-15 12:00:31 EDT
The example file is AD centric since the AD is currently a predominant option. I frankly do not see a bug here. The defaults are correct for a generic POSIX case but for AD you need to use the specific attributes that are given in the example.

Would you mind providing more details about why you think this is wrong otherwise we will close the bug.
Comment 2 Stephen Gallagher 2011-03-15 12:05:01 EDT
This is not a bug. That line in the example config file is attempting to demonstrate how to set the UID and gid values when using an older Active Directory as opposed to a POSIX-compliant LDAP server.