Bug 687943

Summary: udev rules silently ignore RUN+= action at boot time.
Product: [Fedora] Fedora Reporter: Joe <joe-barnett>
Component: udevAssignee: Harald Hoyer <harald>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 14CC: harald, jonathan
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-03-16 06:48:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Joe 2011-03-15 14:58:33 EDT
Description of problem: udev RUN+= command is silently ignored when rule is applied at boot but operates normally when system is running. This is shown when connecting USB hardware.  I have tried an Arduino Diecimila and a WinTV USB tuner.


Version-Release number of selected component (if applicable): udevd 145


How reproducible: Very, it seems independent of USB hardware connected


Steps to Reproduce: Using a WinTV USB tuner for example
1. Create udev rule ' KERNEL=="tuner0", SYMLINK+="wintv", RUN+="/bin/touch /tmp/wintv.log" '
2. plug in WinTV USB
3. Reboot with WinTV USB plugged in
  
Actual results:
After reboot the symlink /dev/wintv is present linking to /dev/video0 but the empty file /tmp/wintv.log is not present


Expected results:
The symlink /dev/wintv should be present and also the empty file /tmp/wintv.log should be present

Additional info:
The udev rule functions correctly if the USB device is plugged in with the system running.  This has been tried on Fedora 12 i686, Fedora 14 i686, Fedora 14 x86_64.   

This has also been tested and found to work correctly from boot on Ubuntu 10.04 and 10.10.
Comment 1 Harald Hoyer 2011-03-16 06:48:46 EDT
/tmp is not yet writeable at boot time...
Try:
KERNEL=="tuner0", SYMLINK+="wintv", RUN+="/bin/touch /dev/wintv.log" 

and check /dev/wintv.log