Bug 68833

Summary: Video garbled during installation
Product: [Retired] Red Hat Linux Reporter: Gordon Messmer <gordon.messmer>
Component: XFree86Assignee: Mike A. Harris <mharris>
Status: CLOSED CURRENTRELEASE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: katzj, knutsen, msf
Target Milestone: ---Keywords: MoveUpstream
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: 9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-13 06:32:03 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 82784    
Attachments:
Description Flags
XF86Config from install none

Description Gordon Messmer 2002-07-14 19:50:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
Feedback on video during install was requested in release notes:
On my NVidia GeForce 2MX, video became garbled during the installation.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
Install from CDROM.  Leave system idle during package installation.  Video
became garbled (actually looked like it had zoomed in to a small area in the
center of the screen).  I believe that I switched to a tty and back to correct
the problem.

Additional info:

# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8367 [KT266]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8367 [KT266 AGP]
00:0c.0 Ethernet controller: Linksys Network Everywhere Fast Ethernet 10/100
model NC100 (rev 11)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. USB (rev 18)
00:11.3 USB Controller: VIA Technologies, Inc. USB (rev 18)
00:11.4 USB Controller: VIA Technologies, Inc. USB (rev 18)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio
Controller (rev 10)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX] (rev b2)
Comment 1 Michael Fulbright 2002-07-17 16:51:42 EDT
Did the screensaver kick in by chance?
Comment 2 Gordon Messmer 2002-07-26 00:57:47 EDT
Well, moving the mouse didn't cause the display to correct itself.  I'm pretty
sure that I had to switch VC's (there and back again) to fix the display.  I
thought that there was no screensaver running during the install?
Comment 3 Marius Andreiana 2002-07-31 07:14:08 EDT
I can't find the bug # with text mode installs colors being wrong.
Just wanted to mention it's still wrong in limbo2
Comment 4 Michael Fulbright 2002-08-05 11:58:39 EDT
Could you do the following?

1) Boot into install and make sure display is garbled.
2) Put in a blank floppy.
3) mke2fs /dev/fd0
4) mkdir /tmp/a
5) mount /dev/fd0 /tmp/a
6) cp /tmp/XF86Config.text /tmp/a
7) umount /tmp/a

and then attach the file from the floppy to this bug report?
Comment 5 Gordon Messmer 2002-08-20 23:45:39 EDT
Created attachment 71824 [details]
XF86Config from install
Comment 6 Gordon Messmer 2002-08-20 23:54:46 EDT
During four installs (one upgrade, three clean), I've only seen the screen
garble once.  This is the config file from the last install.  (I thought I'd not
selected "sometimes" reproducable)
Comment 7 Michael Fulbright 2002-08-23 11:22:53 EDT
We've seen this to, but it surely is a X server bug.

Not sure there is much we can do to fix since its so intermittant.
Comment 8 Mike A. Harris 2002-08-23 22:12:12 EDT
Any video driver related problems need to be reproduceable without
the installer in order to effectively debug them.

Using the "nv" driver with the config file that anaconda uses during
install, can you reproduce this at all in any way?  If you can cause
it to happen even intermittently, we may be able to troubleshoot
it and workaround.

Without a way of easily reproducing it though, as msf says, it isn't
likely very resolveable.
Comment 9 Gordon Messmer 2002-08-24 02:57:46 EDT
Can do.  I'll start using that config file tomorrow.  Primarily the difference
between the .test and the one I'm using now is the presence of "DisplaySize" in
the .test file, the bit depth, and the resolutions available.

Should I go so far as to actually run in 800x600?
Comment 10 Gordon Messmer 2002-08-24 22:51:20 EDT
Curiosity forces me to ask:
Where did the DisplaySize setting in the XF86Config.test file come from?  It's
nowhere near accurate for my monitor, and seems like it could be left out.

Also, "dpms" may not be appropriate for the OS installation.  Users might not
expect it at that point; they may think that it has too much computer in it, and
not enough installer.
Comment 11 Mike A. Harris 2002-08-26 17:50:54 EDT
The DisplaySize option is put in the config file by anaconda as far
as I know.  I don't know what the reasoning for it is however, so
I'll leave that to msf or jeremy to answer.

>Also, "dpms" may not be appropriate for the OS installation.  Users
>might not expect it at that point; they may think that it has too
>much computer in it, and not enough installer.

The above paragraph makes absolutely no sense to me.  Can you repeat
that in easily digestible English perhaps?

Comment 12 Gordon Messmer 2002-08-26 18:26:44 EDT
Sorry.  I meant that most installers don't turn off the monitor during
installation.  It's probably no big deal... I just thought it might be
unexpected for the monitor to go into power saving state while the installer was
running.
Comment 13 Mike A. Harris 2003-02-25 08:08:45 EST
Not sure why DPMS would be getting activated at installation time, but
it wouldn't likely be an XFree86 bug.  It would more likely be an installer
bug, but that wouldn't be related to video garbling during installation,
so that would qualify as a separate bug report.

I'm unable to acquire documentation from Nvidia however to understand
how their chips work.  This issue will require Nvidia to troubleshoot the
driver and fix it.
Comment 14 Mike A. Harris 2003-04-12 12:15:21 EDT
Please test this video card with Red Hat Linux 9 and if the problem persists,
it is recommended that you file a bug report at http://bugs.xfree86.org
which will get to the nv driver maintainer whom works right at Nvidia.

Please indicate if it works or not, and if not, add a link here to your
upstream bug report so I can track the issue upstream and backport any
fixes that may be made by the maintainer.

Thanks.
Comment 15 Gordon Messmer 2003-04-13 05:33:57 EDT
I haven't been able to reproduce the problem.
Comment 16 Mike A. Harris 2003-04-13 06:32:03 EDT
Ok, thanks for the update.  Closing CURRENTRELEASE of Red Hat Linux 9