Bug 688822

Summary: [ja_JP] Wrong translation of 'has been unregistered'
Product: Red Hat Enterprise Linux 6 Reporter: Kenichi Takemura <ktakemur>
Component: subscription-managerAssignee: Bryan Kearney <bkearney>
Status: CLOSED ERRATA QA Contact: QE Internationalization Bugs <qe-i18n-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: ebaak, eng-l10n-bugs, syeghiay
Target Milestone: rcKeywords: Translation
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-05-19 09:40:36 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Kenichi Takemura 2011-03-18 02:39:00 EDT
Description of problem:

Displayed string when running subscription-manager 'register --force' and 'unregister' command line has wrong translations.

$ sudo subscription-manager unregister
システムは未登録です

This prefers 

$ sudo subscription-manager unregister
システムの登録は解除されました


$ sudo subscription-manager register --force --username=xxxx -password=xxxx
UUID ee7eb6da-da0f-41c4-bc2f-962bc805d28a を持つシステムは未登録です。
9cc4d2d3-eec9-444e-8f94-d16766501747 localhost.localdomain

This is replaced by

$ sudo subscription-manager register --force --username=xxxx -password=xxxx
UUID ee7eb6da-da0f-41c4-bc2f-962bc805d28a を持つシステムの登録は解除されました。
9cc4d2d3-eec9-444e-8f94-d16766501747 localhost.localdomain


Version-Release number of selected component (if applicable):

subscription-manager-firstboot-0.95.4-1.el6.x86_64
subscription-manager-0.95.4-1.el6.x86_64
subscription-manager-gnome-0.95.4-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  # LANG=ja_JP.utf8 subscription-manager register
2.  # LANG=ja_JP.utf8 subscription-manager register --force
3.  # LANG=ja_JP.utf8 subscription-manager unregister
  
Actual results:
シシステムは未登録です is wrong translation.

Expected results:
システムの登録は解除されました is proper translation.

Additional info:
Comment 2 RHEL Product and Program Management 2011-04-03 22:02:36 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Bryan Kearney 2011-04-05 15:25:07 EDT
The translation has changed in 0.96.6. Can you please re-verify there?
Comment 4 Kenichi Takemura 2011-04-06 20:20:13 EDT
I verified this bug.

$ rpm -q subscription-manager
subscription-manager-0.95.6-1.el6.i686

$ sudo subscription-manager unregister
このシステムは現在登録されていません

$ sudo subscription-manager register --force --username=xxxx --password=xxxx
UUID 0a9a4463-66be-4d3e-a85c-058996dce7b4 を持つシステムの登録は解除されました
1c33ca58-54e1-47c2-9b58-9595bb86ef86 dhcp-1-167.bne.redhat.com

$ sudo subscription-manager unregister
システムの登録は解除されました
Comment 5 errata-xmlrpc 2011-05-19 09:40:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html
Comment 6 errata-xmlrpc 2011-05-19 09:40:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0611.html