Bug 689964

Summary: kde-plasma-networkmanagement: VPN authentication regression
Product: [Fedora] Fedora Reporter: Kevin Kofler <kevin>
Component: kde-plasma-networkmanagementAssignee: Rex Dieter <rdieter>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 14CC: amessina, jklimes, kevin, paulo.fidalgo.pt, peter.levart, rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: kde-plasma-networkmanagement-0.9-0.40.20110323.fc13 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-01 18:20:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Kevin Kofler 2011-03-22 21:21:38 UTC
Description of problem:
We have several reports of VPN authentication not working with current kde-plasma-networkmanagement builds when KWallet is enabled.

Version-Release number of selected component (if applicable):
kde-plasma-networkmanagement-0.9-0.34.20110217.fc14 (?)
kde-plasma-networkmanagement-0.9-0.35.20110221.fc14 (*)
kde-plasma-networkmanagement-0.9-0.36.20110308.fc14 (?)
kde-plasma-networkmanagement-0.9-0.37.20110310.fc14 (?)
kde-plasma-networkmanagement-0.9-0.38.20110310.fc14 (?)
kde-plasma-networkmanagement-0.9-0.39.20110314.fc14 (*)
(*) = confirmed report(s), (?) = probably affected too

How reproducible:
Appears to be always reproducible according to user reports

Steps to Reproduce:
(requires a VPN with constant password to reproduce)
1. Make sure storing secrets in KWallet is enabled (the default)
2. Configure a VPN with stored password
  
Actual results:
Authentication successful.

Expected results:
Authentication fails.

Additional info:
This is NOT the same issue as bug #682972, which is about trouble with WEP and WPA authentication when KWallet is DISABLED.

Comment 1 Kevin Kofler 2011-03-22 21:26:32 UTC
> Actual results:
> Authentication successful.
>
> Expected results:
> Authentication fails.

Oops. ;-)

This should of course read:
Actual results:
Authentication fails.

Expected results:
Authentication successful.

Comment 2 Jirka Klimes 2011-03-23 09:28:22 UTC
I've tested with upstream networkmanagement master and it appears to work.
The fixing commit seems to be 9e167b9f62b5df97a8cda333fbc6418772a5088c

Comment 3 Fedora Update System 2011-03-24 13:23:24 UTC
kde-plasma-networkmanagement-0.9-0.40.20110323.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.40.20110323.fc13

Comment 4 Fedora Update System 2011-03-24 13:24:05 UTC
kde-plasma-networkmanagement-0.9-0.40.20110323.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.40.20110323.fc14

Comment 5 Fedora Update System 2011-03-24 13:24:36 UTC
kde-plasma-networkmanagement-0.9-0.40.20110323.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.40.20110323.fc15

Comment 6 Paulo Fidalgo 2011-03-28 10:48:55 UTC
With those updates my problems were gone.

Thanks a lot for your effort on this issue.

Comment 7 Peter Levart 2011-04-01 15:36:33 UTC
I experienced this bug too on F14. The bug manifested also in the Network Control GUI which did not pick the VPN password from the KDE Wallet (the password field was blanked when the GUI was re-opened). With the above presented updated packages, this now works and I can now store the password in the KDE Wallet. Thanks.

Comment 8 Paulo Fidalgo 2011-04-01 15:48:05 UTC
Peter, use the mentioned updates and it should solve your problem, at least for me they did.

Comment 9 Fedora Update System 2011-04-01 18:20:23 UTC
kde-plasma-networkmanagement-0.9-0.40.20110323.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-04-01 18:27:47 UTC
kde-plasma-networkmanagement-0.9-0.40.20110323.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.