Bug 6902

Summary: GUI install will try to create ilegal partitions on mylex raid
Product: [Retired] Red Hat Linux Reporter: jlewis
Component: installerAssignee: Michael Fulbright <msf>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-22 16:22:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jlewis 1999-11-11 00:59:15 UTC
I just tried my first install on a box with a Mylex
Acceleraid 200 controller.  The Mylex docs say the driver
supports partitions p1 - p7, i.e. /dev/rd/c0d0p1 through
/dev/rd/c0d0p7.  I tried to install with:
256mb	/
256mb	swap
256mb	/tmp
2000mb	/usr
<remainder>	/var

This is only 5 partitions, yet disk druid created them as
/dev/rd/c0d0p1
/dev/rd/c0d0p5
/dev/rd/c0d0p6
/dev/rd/c0d0p7
/dev/rd/c0d0p8

I don't know why disk druid likes to create just 1 primary
and everything else in an extended partition starting at
partition 5, but it breaks the mylex raid driver.  This
resulted in my /var partition not existing.

I was able to get around this by switching to virtual
console 2, running fdisk by hand, then rebooting and letting
the GUI disk druid use the existing partitions.

Comment 1 Jay Turner 1999-11-29 20:41:59 UTC
This issue has been assigned to a developer for further action.

Comment 2 Michael Fulbright 2000-02-22 16:22:59 UTC
The fdisk will be available via the GUI in future release to handle this problem
more cleanly.