Bug 690234

Summary: Command "yum groupinstall" fails
Product: Red Hat Enterprise Linux 6 Reporter: Dimitar Yordanov <dyordano>
Component: yum-rhn-pluginAssignee: Miroslav Suchý <msuchy>
Status: CLOSED ERRATA QA Contact: Martin Minar <mminar>
Severity: high Docs Contact:
Priority: high    
Version: 6.1CC: cperry, jhutar, mkoci, mminar
Target Milestone: rcKeywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: yum-rhn-plugin-0.9.1-22.el6 Doc Type: Bug Fix
Doc Text:
There was bug in command "yum groupinstall", which was caused by populating yum cache twice, this is now fixed.
Story Points: ---
Clone Of:
: 1056048 (view as bug list) Environment:
Last Closed: 2011-05-19 09:06:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1056048    
Attachments:
Description Flags
yum groupinstall none

Description Dimitar Yordanov 2011-03-23 12:42:29 EDT
Created attachment 487089 [details]
yum groupinstall

Description of problem:
Command "yum groupinstall"  FAILs

Version-Release number of selected component (if applicable):
RHEL6.1
rhn-check-1.0.0-57.el6.noarch
rhn-client-tools-1.0.0-57.el6.noarch
rhn-setup-1.0.0-57.el6.noarch
rhn-setup-gnome-1.0.0-57.el6.noarch
yum-rhn-plugin-0.9.1-20.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1.rpm -q rhn-check rhn-client-tools rhn-setup rhn-setup-gnome yum-rhn-plugin 
rhn-check-1.0.0-57.el6.noarch
rhn-client-tools-1.0.0-57.el6.noarch
rhn-setup-1.0.0-57.el6.noarch
rhn-setup-gnome-1.0.0-57.el6.noarch
yum-rhn-plugin-0.9.1-20.el6.noarch

2.yum groupinstall  Desktop (or other that is not installed)
  
Actual results:

Loaded plugins: product-id, rhnplugin, subscription-manager
Updating Red Hat repositories.
Setting up Group Process
No packages in any requested group available to install or update


Expected results:
# yum groupinstall  Desktop
Loaded plugins: product-id, rhnplugin, subscription-manager
Updating Red Hat repositories.
Setting up Group Process
Resolving Dependencies
--> Running transaction check
---> Package NetworkManager.x86_64 1:0.8.1-5.el6_0.1 will be installed
--> Processing Dependency: ppp = 2.4.5 for package: 1:NetworkManager-0.8.1-5.el6_0.1.x86_64
--> Processing Dependency: NetworkManager-glib = 1:0.8.1-5.el6_0.1 for package: 1:NetworkManager-0.8.1-5.el6_0.1
...




Additional info:
See attachment.
Comment 1 Dimitar Yordanov 2011-03-23 13:08:53 EDT
The bug is applicable for the following packages as well.

[root@amd]# rpm -q rhn-check rhn-client-tools rhn-setup rhn-setup-gnome yum-rhn-plugin 
rhn-check-1.0.0-53.el6.noarch
rhn-client-tools-1.0.0-53.el6.noarch
rhn-setup-1.0.0-53.el6.noarch
rhn-setup-gnome-1.0.0-53.el6.noarch
yum-rhn-plugin-0.9.1-18.el6.noarch
Comment 3 Miroslav Suchý 2011-03-30 04:07:56 EDT
Yes, it is regression.
Comment 5 Miroslav Suchý 2011-04-01 16:18:35 EDT
Fixed in spacewalk.git in commit 9193b78abe2333e353488e9f38d6ed3eacc7ed7c
Comment 6 Miroslav Suchý 2011-04-04 03:45:19 EDT
Cherry picked to satellite.git as commit 133acacca33e5856030951320bcc7515a5912e7f
Comment 9 Miroslav Suchý 2011-05-17 08:44:35 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
There was bug in command "yum groupinstall", which was caused by populating yum cache twice, this is now fixed.
Comment 10 errata-xmlrpc 2011-05-19 09:06:26 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0565.html