Bug 690298

Summary: claws-mail not an option for default mailer in GNOME3
Product: [Fedora] Fedora Reporter: Jeff Layton <jlayton>
Component: claws-mailAssignee: Andreas Bierfert <andreas.bierfert>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 15CC: andreas.bierfert, bugs.michael, jerome.benoit, steved, tomspur
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: claws-mail-plugins-3.7.10-12.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-26 19:17:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
update desktop database in post and postun none

Description Jeff Layton 2011-03-23 20:07:39 UTC
Opening this as a claws-mail bug, but it may be a GNOME one...

I'm using GNOME3 (gnome-shell). When I go to "System Settings->System Info->Default Applications", it allows me to pick Claws Mail as the default Calendar application, but does not allow me to pick it as the default Mail application.

Comment 1 Michael Schwendt 2011-03-23 20:45:47 UTC
Oh, this affects many more mailers. Adding

  MimeType=x-scheme-handler/mailto;

to the claws-mail.desktop file and running "update-desktop-database" fixes it already. There are more MIME types that could be useful, e.g. Evolution sets:

  MimeType=text/calendar;text/x-vcard;text/directory;application/mbox;message/rfc822;x-scheme-handler/mailto;

Comment 2 Michael Schwendt 2011-03-23 21:13:55 UTC
is also fixed in upstream cvs, btw

Comment 3 Andreas Bierfert 2011-03-24 11:22:40 UTC
I have seen the upstream commit a while back when I switch the desktop file to the upstream version. Lets see if we get a new claws release soon. Otherwise I will 'backport' the commit.

Comment 4 Fedora Update System 2011-03-24 22:50:56 UTC
sylpheed-3.1.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/sylpheed-3.1.0-2.fc15

Comment 5 Fedora Update System 2011-03-29 03:51:02 UTC
sylpheed-3.1.0-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2011-04-01 16:55:35 UTC
claws-mail-3.7.9-0.1.20110329.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/claws-mail-3.7.9-0.1.20110329.fc15

Comment 7 Fedora Update System 2011-04-02 02:47:01 UTC
Package claws-mail-3.7.9-0.1.20110329.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing claws-mail-3.7.9-0.1.20110329.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/claws-mail-3.7.9-0.1.20110329.fc15
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-04-10 11:24:17 UTC
libetpan-1.0.1-0.2.20110312cvs.fc14,claws-mail-3.7.9-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libetpan-1.0.1-0.2.20110312cvs.fc14,claws-mail-3.7.9-1.fc14

Comment 9 Fedora Update System 2011-04-10 11:24:28 UTC
libetpan-1.0.1-0.2.20110312cvs.fc15,claws-mail-3.7.9-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libetpan-1.0.1-0.2.20110312cvs.fc15,claws-mail-3.7.9-1.fc15

Comment 10 Fedora Update System 2011-05-01 20:55:47 UTC
libetpan-1.0.1-0.2.20110312cvs.fc14, claws-mail-plugins-3.7.9-2.fc14, claws-mail-3.7.9-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-05-03 04:49:52 UTC
libetpan-1.0.1-0.2.20110312cvs.fc15, claws-mail-3.7.9-2.fc15, claws-mail-plugins-3.7.9-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Michael Schwendt 2011-11-04 11:46:52 UTC
$ rpm -q --scripts claws-mail
$

Actually, the fix is incomplete because the scriptlets are missing:
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#desktop-database

Comment 13 Michael Schwendt 2011-11-04 11:46:56 UTC
*** Bug 751239 has been marked as a duplicate of this bug. ***

Comment 14 Jérôme Benoit 2011-11-04 13:01:41 UTC
Created attachment 531762 [details]
update desktop database in post and postun

Comment 15 Michael Schwendt 2011-11-30 21:45:19 UTC
Fix committed to Rawhide git.

Comment 16 Fedora Update System 2011-12-12 22:59:23 UTC
claws-mail-3.7.10-7.fc16,claws-mail-plugins-3.7.10-10.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/claws-mail-3.7.10-7.fc16,claws-mail-plugins-3.7.10-10.fc16

Comment 17 Fedora Update System 2011-12-13 21:53:43 UTC
Package claws-mail-3.7.10-7.fc16, claws-mail-plugins-3.7.10-10.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing claws-mail-3.7.10-7.fc16 claws-mail-plugins-3.7.10-10.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17063/claws-mail-3.7.10-7.fc16,claws-mail-plugins-3.7.10-10.fc16
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2011-12-26 19:17:28 UTC
claws-mail-plugins-3.7.10-12.fc16, claws-mail-3.7.10-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.