Bug 690398

Summary: Preupgrade installs unbootable upgrade system
Product: [Fedora] Fedora Reporter: Matthias Runge <mrunge>
Component: preupgradeAssignee: Richard Hughes <rhughes>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 14CC: greenrd, rhughes
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-11 05:51:37 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Matthias Runge 2011-03-24 04:28:21 EDT
Description of problem:

after executing preupgrade (on f14)

Version-Release number of selected component (if applicable):
I'm not sure, if this is really preupgrade related
preupgrade-1.1.8-1.fc14.noarch

How reproducible:
every time, different systems

Steps to Reproduce:
1. preupgrade to f15 
2. reboot to install system
3.
  
Actual results:
install system shows black screen, blinking cursor. 


Expected results:
boot into anaconda to install/upgrade system


Additional info:
tried this in virtual box and on real (not ancient, about 3 years old) hardware.
/boot/upgrade/vmlinuz and /boot/upgrade/initrd get installed, grub entry is written, it looks ok.
Comment 1 Robin Green 2011-04-22 04:15:54 EDT
I discovered that on my machine, although it looks to be doing nothing, it does actually work after a while.
Comment 2 Matthias Runge 2011-05-20 07:05:09 EDT
Latest version of preupgrade (1.1.9) fixes this.