Bug 690920

Summary: [abrt] gtkwave-3.3.15-1.fc14: inflate: Process /usr/bin/gtkwave was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Jeff <1nomdeplume>
Component: gtkwaveAssignee: Paul Howarth <paul>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 14CC: paul
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:b4fa3e4b431528579a22e787ae019d1569794486
Fixed In Version: gtkwave-3.3.20-2.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-07 11:01:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
File: backtrace none

Description Jeff 2011-03-25 19:49:31 UTC
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 124281 bytes
cmdline: gtkwave dump.lx2
component: gtkwave
Attached file: coredump, 34598912 bytes
crash_function: inflate
executable: /usr/bin/gtkwave
kernel: 2.6.35.11-83.fc14.i686.PAE
package: gtkwave-3.3.15-1.fc14
rating: 4
reason: Process /usr/bin/gtkwave was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1301082402
uid: 500

How to reproduce
-----
1. Reading a lxt2 format dump file
2. Try loading saved waveform file while dump file is being generated
3. crash.

Comment 1 Jeff 2011-03-25 19:49:32 UTC
Created attachment 487665 [details]
File: backtrace

Comment 2 Fedora Update System 2011-03-29 10:28:21 UTC
gtkwave-3.3.20-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gtkwave-3.3.20-2.fc14

Comment 3 Fedora Update System 2011-03-29 10:28:28 UTC
gtkwave-3.3.20-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gtkwave-3.3.20-2.fc13

Comment 4 Fedora Update System 2011-03-29 10:28:35 UTC
gtkwave-3.3.20-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gtkwave-3.3.20-2.fc15

Comment 5 Paul Howarth 2011-03-29 10:31:03 UTC
Is this crash repeatable? Can you please try the updated version from Comment #2, which contains a tentative fix from the program's author.

Comment 6 Jeff 2011-03-30 12:33:23 UTC
(In reply to comment #5)
> Is this crash repeatable? Can you please try the updated version from Comment
> #2, which contains a tentative fix from the program's author.

I installed the update from updates-testing. I tried to reproduce the bug using the same simulation as before and it works fine.  I may have changed the .sav file though since some of the signal names changed.  Thanks for your work on this, it is a great program.

Comment 7 Paul Howarth 2011-03-30 12:39:33 UTC
Was/is the crash repeatable with the old version? You could try it using "yum downgrade gtkwave".

Comment 8 Fedora Update System 2011-04-03 04:23:34 UTC
gtkwave-3.3.20-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Jeff 2011-04-03 05:44:28 UTC
(In reply to comment #7)
> Was/is the crash repeatable with the old version? You could try it using "yum
> downgrade gtkwave".

I am not able to reproduce the crash with either version, but I hadn't slept for a few days at the time of the crash and it may have been intermittent.

Comment 10 Fedora Update System 2011-04-06 22:32:14 UTC
gtkwave-3.3.20-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-04-06 22:36:43 UTC
gtkwave-3.3.20-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-04-30 17:43:02 UTC
gtkwave-3.3.21-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gtkwave-3.3.21-1.fc14

Comment 13 Fedora Update System 2011-04-30 17:43:15 UTC
gtkwave-3.3.21-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/gtkwave-3.3.21-1.el6

Comment 14 Fedora Update System 2011-04-30 17:43:26 UTC
gtkwave-3.3.21-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gtkwave-3.3.21-1.fc13

Comment 15 Fedora Update System 2011-04-30 17:43:37 UTC
gtkwave-3.3.21-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gtkwave-3.3.21-1.fc15

Comment 16 Fedora Update System 2011-05-05 05:08:12 UTC
gtkwave-3.3.21-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2011-05-09 01:51:49 UTC
gtkwave-3.3.21-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2011-05-09 01:52:21 UTC
gtkwave-3.3.21-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2011-05-16 21:03:49 UTC
gtkwave-3.3.21-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.