Bug 692381

Summary: missing parseSpec in librpmbuild.so
Product: [Fedora] Fedora Reporter: Jacek Pawlyta <cunio>
Component: rpmAssignee: Panu Matilainen <pmatilai>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 15CC: a.badger, comcast.really.sucks, ffesti, jnovy, pmatilai, sergio
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-01 05:03:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jacek Pawlyta 2011-03-31 07:40:16 UTC
Description of problem:
Hi,
 
I installed Air on 64 bit fedora 15 alpha, but I can't install any Air application. The Air Install.log contains information about missing parseSpec symbol in librpmbuild.so
 
 
 
[ERR] Native installation package creation failed: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="Unhandled exceptio
n Error: Error creating the package /opt/Adobe AIR/Versions/1.0/Resources/rpmbuilder error : symbol not found: parseSpec, /usr/lib/librpmbuild.so: undefined symbol: parseSpec error :
 
 
 
I have installed:

rpm-4.9.0-4.fc15.x86_64
rpm-build-4.9.0-4.fc15.x86_64
rpm-build-libs-4.9.0-4.fc15.i686
rpm-build-libs-4.9.0-4.fc15.x86_64
rpm-devel-4.9.0-4.fc15.i686
rpm-devel-4.9.0-4.fc15.x86_64
rpm-libs-4.9.0-4.fc15.i686
rpm-libs-4.9.0-4.fc15.x86_64
 
adobeair-2.6.0-19120.i386

Comment 1 Panu Matilainen 2011-04-01 05:03:52 UTC
Yes, the entire librpmbuild API has changed in rpm 4.9.x and parseSpec() no longer exists, it's been replaced by a new saner interface known as rpmSpecParse(). Air (whatever it is, apparently some Adobe proprietary app) appears to be cheating against soname changes by using the non-versioned -devel .so symlink and now gets burned because of it. It'd be much better off launching rpmbuild than using the librpmbuild API.

Comment 2 Need Real Name 2011-06-18 13:45:49 UTC
for anyone else researching this issue:

I'm sure that Mr. (Mrs?) Matilainen is correct, recent changes in RPM broke Adobe Air installer, and that it is up to Adobe to fix this.

However, Adobe dropped linux support for Air as of this week (June 14 2011), so this likely marks the end of the road for Air applications on linux.

I think I read something that Adobe might release a 'porting kit' for Air on linux; if that is true, perhaps air support can be resurrected.  

Mostly this should serve as a warning for developers -- if you use proprietary tools, this is the risk ... if the vendor drops support, your customers are stranded and will look elsewhere.

Comment 3 Sergio Basto 2012-04-24 18:00:01 UTC
solution here : 
http://forums.fedoraforum.org/showpost.php?p=1499668&postcount=28