Bug 693806

Summary: unhandled exception during install
Product: [Fedora] Fedora Reporter: monobello
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 14CC: anaconda-maint-list, jonathan, joost.ringoot, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-09 16:32:45 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
bugreport none

Description monobello 2011-04-05 11:52:47 EDT
Description of problem:
Shortly after installing Fedora 14, when booting I couldn't reach the login
screen. It would boot to the blue screen with circle with an F in the middle
and that was it. After an hour nothing had happened.  I tried this several
times. I decided to reinstall but then got and an "unhandled exception" when examining storage devices. I tried "rescue system option" at boot but had the same problem with it as well. Next I tried a Live Fedora 14 CD and was 
able to get farther into the installer. I was able to get to the "custom layout" page and list the disc allocation. Everything was fine except for "root" in the LVM. "root"'s filesystem was listed as "unknown". I tried changing to "ext4" and continue and I got the "unhandled exception" again. So I tried to delete "root" the next time and also got an "unhandled exception".  Then a power failure happened and I had to reboot the Live CD.
This time when I did the install to disc and got the "custom layout screen"
everything was fine. There was no problem with "root" or any or the other
volumes.  So the went ahead and did a successful install. The reboot came
up just fine. A couple days later the same thing happened again and I wasn't
able to get to the login screen. At this point I decided to go back to Fedora
13. There is also something interesting I found. In the "custom layout"
if you check format for and existing volume and exit this screen and then come to the same volume uncheck the format. It says "unknown" for the
file system, the same problem I was having with "root". I think we should
reread the volume entry from disc when the format option is unchecked. I'm
thinking since I got a different result after the power failure, that there
may be an unitialized variable somewhere.

This is my disc layout (2 discs)

VolGroup00 on disc1, VolGroup01 on disc2
boot    /boot     1000   ext4
swap              8000   ext4
VolGroup00
   root     /       200000  ext4
   home     /home   200000  ext4
   samba    /samba   40000  ext4
   audio    /audio  350000  ext4
   vm       /vm     200000  ext4
VolGroup01
   backup   /backup 380000  ext4


Version-Release number of selected component (if applicable):
14.22  If I remember correctly.

How reproducible:
Hard to reproduce.  Intermittent

Actual results:
unhandled exception screen

Expected results:
Normal install

Additional info:
Comment 1 Chris Lumens 2011-04-05 11:59:21 EDT
Please attach the complete traceback to this bug report.
Comment 2 monobello 2011-04-05 12:44:09 EDT
I did save the exception into a file in /tmp.  However because this was a Live CD boot, when the power failure happened and I had to reboot, I lost the file. Sorry.
Comment 3 Chris Lumens 2011-04-05 12:46:18 EDT
Well, if you can reproduce it, please attach it.  If not, I don't really know that there's anything we can do.
Comment 4 Joost Ringoot 2011-12-15 07:55:06 EST
Created attachment 547217 [details]
bugreport

I have also an unhandled exception during install of Scientific Linux 6.1. Attached is what I could safe as bugreport
Comment 5 Joost Ringoot 2011-12-15 07:58:44 EST
(In reply to comment #4)
> Created attachment 547217 [details]
> bugreport
> 
> I have also an unhandled exception during install of Scientific Linux 6.1.
> Attached is what I could safe as bugreport

For me the problem is consistent:
normal video boot does,'t work.
This is what I get when I try to install from the livecd via reduced graphics boot.

The livecd appears to work otherwise.
Comment 6 Joost Ringoot 2011-12-15 08:00:15 EST
normal video boot doesn't work at all.
I can get further  with reduced graphics, but I get this almost immediatly during install
Comment 7 Chris Lumens 2012-02-09 16:32:45 EST

*** This bug has been marked as a duplicate of bug 663294 ***