Bug 693862

Summary: saslwrapper: Rebase to 0.10
Product: Red Hat Enterprise Linux 6 Reporter: Justin Ross <jross>
Component: saslwrapperAssignee: Justin Ross <jross>
Status: CLOSED ERRATA QA Contact: Jeff Needle <jneedle>
Severity: unspecified Docs Contact:
Priority: medium    
Version: 6.1CC: ddumas, jneedle, tross
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: saslwrapper-0.10-1.el6 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-05-19 10:30:56 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Diff between released and proposed rebase none

Description Justin Ross 2011-04-05 14:55:20 EDT
Requesting rebase to 0.10 for saslwrapper, a component used by mrg messaging
Comment 1 RHEL Product and Program Management 2011-04-05 14:57:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Justin Ross 2011-04-05 15:51:07 EDT
Background for request:

there's a fix in the 0.10 bits.  saslwrapper is something that ought to be rebased with the other mrg components, but we haven't turned to it until now.  if the rebase is rejected, we'll patch it to get the fix, but I feel a rebase is more consistent with what we're doing for mrg in general.
Comment 4 Justin Ross 2011-04-05 16:19:17 EDT
Created attachment 490069 [details]
Diff between released and proposed rebase
Comment 5 Justin Ross 2011-04-05 16:20:02 EDT
The changelog associated with the difference:

[jross@nicaea sasl]$ svn log -r 934605:HEAD
------------------------------------------------------------------------
r949126 | gsim | 2010-05-28 03:51:49 -0400 (Fri, 28 May 2010) | 1 line

Patch from Ted Ross to prevent sasl_decode overflow
------------------------------------------------------------------------
r1022224 | tross | 2010-10-13 14:18:45 -0400 (Wed, 13 Oct 2010) | 3 lines

Added -fno-strict-aliasing for all of the swig-generated Python wrappers because
Swig (for Python) generates code that violates the strict aliasing rules.

------------------------------------------------------------------------
r1029521 | robbie | 2010-10-31 19:39:39 -0400 (Sun, 31 Oct 2010) | 2 lines

add ASF licence to various files in the cpp tree

------------------------------------------------------------------------
r1068956 | tross | 2011-02-09 11:08:19 -0500 (Wed, 09 Feb 2011) | 3 lines

NO-JIRA - Replaced m4/ac_pkg_swig.m4 with updated version that works with newer
versions of Swig.

------------------------------------------------------------------------
r1076820 | astitcher | 2011-03-03 16:45:59 -0500 (Thu, 03 Mar 2011) | 1 line

NO-JIRA: Branch for the 0.10 release
------------------------------------------------------------------------
Comment 6 Justin Ross 2011-04-05 16:20:34 EDT
Note that one of the above changes is already present in the released rpms by virtue of a patch.
Comment 12 Denise Dumas 2011-04-19 13:47:47 EDT
ok, trying to clear the relnote flag - the bot may just set it again.
Comment 14 errata-xmlrpc 2011-05-19 10:30:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0809.html