Bug 695492

Summary: on live image, mediacheck has to be manually selected but defaults to not displaying result
Product: [Fedora] Fedora Reporter: Andre Robatino <robatino>
Component: LiveCDAssignee: Matthias Clasen <mclasen>
Status: CLOSED NOTABUG QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: awilliam, bruno, dcantrell, jlaska, kevin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: AcceptedNTH
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-08 21:36:43 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 657621    

Description Andre Robatino 2011-04-11 16:44:34 EDT
Description of problem:
On booting Fedora-15-Beta-i686-Live-Desktop.iso, there is a "Verify and Boot" option in the boot menu. (Haven't checked x86_64, but presumably it's the same.) But it seems unlikely that it's actually verifying anything (I see nothing indicating this even when booting from an extremely slow 12-year old machine). I know that mediacheck is gone from netinst images, is this also true for live? And if there IS an actual verify being done, the user should be made aware of this somehow. So:

1) If live images are no longer intended to include a mediacheck, then "Verify and Boot" should be removed from the boot menu.

2) If there is a mediacheck, then there should be some indication of this fact (a "pass" or "fail" message should be displayed, long enough for the user to see it).

Version-Release number of selected component (if applicable):
Fedora-15-Beta-i686-Live-Desktop.iso
Comment 1 Andre Robatino 2011-04-21 06:21:43 EDT
http://fedoraproject.org/wiki/Fedora_15_Final_Release_Criteria

Proposing this as a F15 Final Blocker under the "menu sanity" requirement - it's not explicit, but I think it's reasonable to expect that each menu item, including "Verify and Boot", actually does what it says. It seems very unlikely to me that there is an actual verify being done, which if true, means that "Boot" and "Verify and Boot" do the same thing. This would fall under "No application may unintentionally appear twice in the menus."
Comment 2 Andre Robatino 2011-04-21 06:24:19 EDT
Reading it again, it looks like the criteria refer to the desktop menus, not the boot menu, but I would think the latter is at least as important.
Comment 3 James Laska 2011-04-21 13:25:42 EDT
Discussed at 2011-04-21 blocker review meeting.  RejectedBlocker, AcceptedNTH.  Seek guidance from bruno, nirik or cwickert to determine how to proceed.
Comment 4 Brian Lane 2011-04-21 13:39:23 EDT
dracut is what actually handles running the mediacheck in this case. code is in 90dmsquash-live/dmsquash-live-root which runs checkisomd5 --verbose 

Running the Beta live desktop in a KVM if you hit ESC when it shows the plymouth progress bar you will see the media check running, or you can remove rhgb from the commandline.

If the check fails dracut will stop the boot with "CD check failed!"
Comment 5 Andre Robatino 2011-04-21 14:10:35 EDT
Sorry for the false alarm - doing what you described, I checked in KVM and VirtualBox booting from the ISO file, and bare metal booting from optical disc, and it's possible to see the check happening.
Comment 6 Andre Robatino 2011-04-28 18:13:17 EDT
So the only question remaining is whether the mediacheck result should be displayed by default. I seem to remember it not being hidden in the past, but don't use live images often so could be wrong.
Comment 7 Kevin Kofler 2011-05-16 16:44:41 EDT
F14 behaved the exact same way.
Comment 8 Adam Williamson 2012-05-08 21:36:43 EDT
sounds like this should be closed.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers