Bug 696492

Summary: Kernel missing after installing F15
Product: [Fedora] Fedora Reporter: R.M. van der Spek <hermanrms>
Component: preupgradeAssignee: Richard Hughes <richard>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 15CC: dherault, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, richard
Target Milestone: ---   
Target Release: ---   
Hardware: other   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-07 14:10:30 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description R.M. van der Spek 2011-04-14 03:05:18 EDT
Description of problem: After having installed Fedora 15 it did not boot. It stopped with halve a page of error messages among which: "Kernel panic -> Unable to mount root". Fortunately I could start F15 with the previous F14-kernel. I looked into /boot/grub/grub.conf and found out there was a line missing for "initrd /boot/initfamfs-2.6.38.2-9.fc15.i686.img" (or something alike). Looking into the /boot-folder I found out there was no img-file for F15. There were for the previous kernels, but not for the newest installed Fedora 15. It must have been a bug in installation (I used 'preupgrade') for I did not alter anything before this error appeared. 


Version-Release number of selected component (if applicable): Fedora 15


How reproducible: Not sure. 


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results: 


Additional info: Running F15 on a Packard Bell Dot S netbook.
Comment 1 dherault 2011-04-15 15:51:22 EDT
Same here. Upgrade with preupgrade too. Corrected after a :

# yum reinstall kernel
Comment 2 R.M. van der Spek 2011-04-16 00:51:53 EDT
Unfortunately this did not work for me. Yum told me it had 'nothing to do'. So I tried uninstalling f15-kernel first. This worked,  but after trying to install it I bumped on the following:


[rmvanderspek@laptop2 ~]$ sudo yum install kernel-2.6.38.2-9.fc15.i686
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
No package kernel-2.6.38.2-9.fc15.i686 available.
Error: Nothing to do


How can there not be a package available?
Comment 3 R.M. van der Spek 2011-04-16 02:35:19 EDT
After removing duplicates it is now installing the F15-kernel. I don't understand why it didn't work before, but does work now. Anyhow: I'm glad it does :).
Comment 4 Fedora End Of Life 2012-08-07 14:10:32 EDT
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping