Bug 696788

Summary: [RFE] Add code in network-scripts to load static arp entries from ethers file
Product: Red Hat Enterprise Linux 6 Reporter: J.H.M. Dassen (Ray) <rdassen>
Component: initscriptsAssignee: initscripts Maintenance Team <initscripts-maint-list>
Status: CLOSED ERRATA QA Contact: qe-baseos-daemons
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: asersen, azelinka, jwest, notting, pknirsch, plautrba, rbinkhor, spurrier
Target Milestone: rcKeywords: FutureFeature, Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: initscripts-9.03.24-1.el6 Doc Type: Enhancement
Doc Text:
Cause There are times when it's needed to load static arp entries early in startup of the system. Change Startup network scripts were changed to set up arp entries from /etc/ether file Results Arp entries defined in /etc/ether file are set ater network started.
Story Points: ---
Clone Of:
: 713759 836282 (view as bug list) Environment:
Last Closed: 2011-12-06 18:09:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 607248, 658636, 713759, 836282    

Description J.H.M. Dassen (Ray) 2011-04-14 20:08:35 UTC
2. What is the nature and description of the request?

Customer has requested to add code in network init script to load static arp
entries from ethers.  

3. Why does the customer need this? (List the business requirements here)

There are times when you want to load static arp entries early in startup of
the system. Doing this in the network script is preferable to make sure other
network services can access network resources.  It appears there is no other
standard way to automatically load these entries currently. 

4. How would the customer like to achieve this? (List the functional
requirements here)

Customer has created and attached a patch to the initscripts package that adds
a few lines to the network script to load static arp entries from the ethers
file. This is very similar to the way static routes are loaded in the network
script.  Customer would like the patch reviewed for possible inclusion in RHEL.

5. For each functional requirement listed in question 4, specify how Red Hat
and the customer can test to confirm the requirement is successfully
implemented.

Internal testing, provide Red Hat test packages to the customer.    

6. Is there already an existing RFE upstream or in Red Hat bugzilla?

No.

7. How quickly does this need resolved? (desired target release)

RHEL 6.2 is the desired release.  

8. Does this request meet the RHEL Inclusion criteria (please review)

Yes.

9. List the affected packages

initscripts

Comment 8 Petr Lautrbach 2011-10-17 11:50:18 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    There are times when it's needed to load static arp entries early in 
startup of the system.

Change
    Startup network scripts were changed to set up arp entries from
/etc/ether file

Results
    Arp entries defined in /etc/ether file are set ater network started.

Comment 9 errata-xmlrpc 2011-12-06 18:09:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1528.html