This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 697523

Summary: The old SysV initscript should be packaged into subpackage when replaced with systemd one
Product: [Fedora] Fedora Reporter: Jóhann B. Guðmundsson <johannbg>
Component: dbusAssignee: David Zeuthen <davidz>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: davidz, lpoetter, mclasen, walters, walters
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-03 17:54:50 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 713562    
Attachments:
Description Flags
I think this patch should satisfie the packaging guidelines and drops sysv support
none
I think this patch should satisfie the packaging guidelines and drops sysv support
none
Spec file patch for dbus none

Description Jóhann B. Guðmundsson 2011-04-18 10:09:24 EDT
Description of problem:

The old SysV initscript should be package into seperate subpackage when replaced with a native systemd one to avoid confusion amongs end users since systemd will use the native systemd service file when it exist by default thus rendering the old sysv obsolete and keeping it around will only confuse users that for one reason or another are editing the sysv init script.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-06-27 08:07:45 EDT
What's the current status on this?

We need this in rawhide the sooner the better.

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
http://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 2 Jóhann B. Guðmundsson 2011-06-30 14:41:50 EDT
Created attachment 510733 [details]
I think this patch should satisfie the packaging guidelines and drops sysv support
Comment 3 Jóhann B. Guðmundsson 2011-06-30 14:44:13 EDT
Created attachment 510735 [details]
I think this patch should satisfie the packaging guidelines and drops sysv support

Minor fix to the trigger run version
Comment 4 Jóhann B. Guðmundsson 2011-07-15 11:07:21 EDT
What's the current status of you are one of few that is not package
native systemd unit in the Base group correctly?

If you dont have the time to fix this should I try to find a proven packager to
do the work for you? 

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 5 Colin Walters 2011-07-18 14:31:19 EDT
(In reply to comment #4)
> What's the current status of you are one of few that is not package
> native systemd unit in the Base group correctly?
> 
> If you dont have the time to fix this should I try to find a proven packager to
> do the work for you? 

Frankly I don't really believe upgrades like this have ever worked reliably; if you've tested the code at all, feel free to commit.

(Did you test it?)
Comment 6 Jóhann B. Guðmundsson 2011-07-18 15:06:44 EDT
I tested building it that's about it I'm not a proven packager however I shall see if I cant find one tomorrow that will review and commit the changes since you are busy.
Comment 7 Jóhann B. Guðmundsson 2011-07-26 18:01:29 EDT
Created attachment 515379 [details]
Spec file patch for dbus

Note this needs to be fixed before thursday thanks.
Comment 8 David Zeuthen 2011-08-03 09:38:06 EDT
Uhm, comment 5 asked for whether you had tested it and you replied in comment 6 that you've only _built_ it. It is not reasonable to then ask for it to be committed if you haven't even tested it.
Comment 9 Jóhann B. Guðmundsson 2011-08-03 09:49:37 EDT
Well it was broken the other patch which is why I came up with a new one ( comment 7 ) and the only reason I'm providing spec patches is to speed up the process it's been ca 4 months ( yup this report is getting 4 months old ) which should have been a sufficient time to find the time to clean the spec file and do an 10 - 20 minute job anyway just review the patch and commit or come up with your own we kinda had wanted this to be done last thursday since we wanted the live alpha compose to be legacy sysv init script free.
Comment 10 David Zeuthen 2011-08-03 09:59:42 EDT
No, no, no. Please realize that it's never a "10-20 minute job" when it comes to something as critical as the D-Bus packages. If they are broken, the system likely won't boot (at least not into any useful state) and you'll ruin the day for a lot of people on Rawhide by pushing them out. This means that you need to test the packages *thoroughly* in addition to just reviewing the changes made to them.

If you had replied something like "yup, I tested the packages and both the upgrade as well as a subsequent reboot worked fine" then I'd more much more likely to commit the patch (after testing it myself, of course).
Comment 11 David Zeuthen 2011-08-03 10:01:41 EDT
Lennart: would you mind skimming through the proposed patch in comment 7 and see if it's correct? Thanks!
Comment 12 Lennart Poettering 2011-08-03 10:05:57 EDT
Looks good!
Comment 13 David Zeuthen 2011-08-03 17:54:50 EDT
OK, I tested the patch and it works both after the update and also after a reboot. Built for f16 here

 http://koji.fedoraproject.org/koji/taskinfo?taskID=3251000