Bug 698186

Summary: bluetooth applet doesn't appear and bluetooth light doesn't activate
Product: [Fedora] Fedora Reporter: Brian G. Anderson <bikehead>
Component: bluezAssignee: Bastien Nocera <bnocera>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 15CC: bnocera, dwmw2, marcel, plautrba
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-05-06 13:24:21 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Brian G. Anderson 2011-04-20 07:47:39 EDT
Description of problem:
After the current software upgrade to bluez, I've lost bluetooth.  I installed a fresh copy of fc15 beta, and out of the box I had no bluetooth.  I played around and used "systemctl enable bluetooth.service" to get the bluetooth daemon to start automatically.  I had to manually start bluetooth-applet and for a while I had an active bluetooth light on my laptop and a bluetooth icon in gnome-shell.  I had hooked up a bluetooth mouse.

After a software upgrade on 4/19/2011 I lost bluetooth again and the above steps don't activate it either.  "systemctl status bluetooth.service" reports:

bluetooth.service - Bluetooth Manager
	  Loaded: loaded (/lib/systemd/system/bluetooth.service)
	  Active: active (running) since Wed, 20 Apr 2011 04:18:21 -0700; 28min ago
	Main PID: 1013 (bluetoothd)
	  CGroup: name=systemd:/system/bluetooth.service
		  └ 1013 /usr/sbin/bluetoothd -n

And when I start bluetooth-applet manually on the command line it just hangs reporting nothing.

Version-Release number of selected component (if applicable):
bluez-4.87-3.fc15.x86_64
gnome-bluetooth-3.0.0-1.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bastien Nocera 2011-05-06 13:24:21 EDT
bluetooth-applet wouldn't do anything because gnome-shell has its own implementation, and we don't want both the gnome-shell and the bluetooth-applet showing up at the same time.

In any case, bug should be fixed in an update shortly.

*** This bug has been marked as a duplicate of bug 694519 ***