Bug 6997

Summary: 6.1 Upgrade script dies if it encounters an unformatted partition.
Product: [Retired] Red Hat Linux Reporter: mjm306
Component: installerAssignee: Michael Fulbright <msf>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-04-28 21:52:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description mjm306 1999-11-14 18:18:59 UTC
I performed a network upgrade (with boot disk via ftp) from 6.0 to 6.1. The install script died while attempting to find the partition where 6.0 was installed. The debug info indicated that it had difficulty reading /dev/hda5.

I ran fdisk. /dev/hda5 was an extended partition that was marked as ext2 but not formatted.

Formatting the partition and re-running the install solved the problem.

Comment 1 Jay Turner 1999-11-22 18:48:59 UTC
This issue has been assigned to a developer for further action.

Comment 2 Michael Fulbright 2000-02-22 18:55:59 UTC
If you were trying to upgrade a machine with a partition which was marked
as Linux Native, but has no valid filesystem on it, bad things are sure to
happen.

Will mark as a request for future development that we handle this case
more robustly.

Comment 3 Erik Troan 2000-04-28 21:23:59 UTC
Fixed in 6.2.