Bug 699945

Summary: find-lang.sh doesn't find *_ca@valencia.qm files
Product: [Fedora] Fedora Reporter: Kevin Kofler <kevin>
Component: rpmAssignee: Jindrich Novy <jnovy>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: rawhideCC: christoph.wickert, ffesti, jnovy, pknirsch, pmatilai
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-27 08:32:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Kevin Kofler 2011-04-27 01:25:01 UTC
Description of problem:
Avogadro 1.0.3 installs the following files:
%lang(ca@valencia) %{_datadir}/avogadro/i18n/avogadro_ca
%lang(ca@valencia) %{_datadir}/avogadro/i18n/libavogadro_ca
which are not found by:
%find_lang libavogadro --with-qt --without-mo
%find_lang avogadro --with-qt --without-mo

Version-Release number of selected component (if applicable):
rpm-4.9.0-7.fc16

How reproducible:
Always.

Steps to Reproduce:
Try to build
http://pkgs.fedoraproject.org/gitweb/?p=avogadro.git;a=tree;h=940f39173c155c8f760b11dfeda88455a5020251;hb=940f39173c155c8f760b11dfeda88455a5020251
(Note: The current revision has a workaround.)
  
Actual results:
error: Installed (but unpackaged) file(s) found:
   /usr/share/avogadro/i18n/avogadro_ca
   /usr/share/avogadro/i18n/libavogadro_ca

Expected results:
The files are found automatically by %find_lang, like all the other .qm files.

Additional info:
The regexes for .qm files simply don't support the @valencia tag. Somebody needs to fix the regexes.

The workaround is to list the files manually, with appropriate %lang directives. (By the way, should I tag the files with %lang(ca@valencia) or just %lang(ca)?)

Comment 1 Jindrich Novy 2011-04-27 08:32:53 UTC
Fixing regular expressions in find-lang seems better way to go. It is now fixed.

find-lang detects the qm file like this:
%lang(ca@valencia) /x86_64-unknown-linux/avogadro/src/avogadro_ca

Assuming it is correct.

Comment 2 Kevin Kofler 2011-04-27 15:23:13 UTC
Uh, no, this is not correct, it should be /usr/share, not /x86_64-unknown-linux. Are you sure you ran the script on the DESTDIR (the %buildroot), not on the BUILD dir?

Comment 3 Jindrich Novy 2011-04-27 17:42:06 UTC
It's ran in a test directory and so x86_64-unknown-linux is a dummy directory for running find-lang.sh. What I had in mind was that assuming %lang(ca@valencia) at the beginning is correct.

Comment 4 Christoph Wickert 2012-07-06 12:14:50 UTC
*** Bug 729336 has been marked as a duplicate of this bug. ***