Bug 699996

Summary: X compose maps not enabled by default
Product: [Fedora] Fedora Reporter: Marko Myllynen <myllynen>
Component: imsettingsAssignee: Akira TAGOH <tagoh>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: i18n-bugs, tagoh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-28 06:22:04 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
imsettings.log with no input method
none
imsettings.log with x compose maps in use none

Description Marko Myllynen 2011-04-27 04:23:59 EDT
Description of problem:
After default Fedora 15 Beta installation the input method in use is "No Input Method", not "Use X compose table". This makes compose sequences from locale specific X compose maps to be unavailable.

There have been few long discussions related to this, see:

https://bugzilla.redhat.com/show_bug.cgi?id=505100
https://bugzilla.redhat.com/show_bug.cgi?id=623931

I'm wondering could XIM be enabled by default in Fedora 15? Either for all or at least for the locales/keyboards listed in:

https://bugzilla.redhat.com/show_bug.cgi?id=623931#c2

Version-Release number of selected component (if applicable):
Fedora 15 Beta
Comment 1 Akira TAGOH 2011-04-27 05:49:58 EDT
Please give me the installed imsettings version and your locale.

You could enable it by the hand from im-chooser say, right?
Comment 2 Marko Myllynen 2011-04-27 08:15:36 EDT
> Please give me the installed imsettings version and your locale.

imsettings-1.2.2-1.fc15.i686 and LC_CTYPE=fi_FI.UTF-8. To quickly check if the fi_FI.UTF-8 compose map is in use you could try, e.g., <Multi_key> <f> <i>. If so, you'll get fi (U+FB01), otherwise no output.

> You could enable it by the hand from im-chooser say, right?

Yes, manually switching to "Use X compose table" works fine. I'm suggesting that it should be considered could it be the default setting.

Thanks.
Comment 3 Akira TAGOH 2011-04-28 04:43:04 EDT
Can you attach $HOME/.imsettings.log?
Comment 4 Marko Myllynen 2011-04-28 04:56:12 EDT
I'll attach the log both with no input method and with X compose maps in use.
Comment 5 Marko Myllynen 2011-04-28 04:56:40 EDT
Created attachment 495455 [details]
imsettings.log with no input method
Comment 6 Marko Myllynen 2011-04-28 04:57:07 EDT
Created attachment 495456 [details]
imsettings.log with x compose maps in use
Comment 7 Akira TAGOH 2011-04-28 05:19:12 EDT
Strange. how did you install it? though I tried to reproduce your problem with changing /etc/sysconfig/i18n to fi_FI.UTF-8 and create a new user, it works fine there. even though it works with ja_JP.UTF-8 in /etc/sysconfig/i18n but simply changed to "Finnish (Finland)" in "Region and Language" on gnome-control-center and re-login.
Comment 8 Marko Myllynen 2011-04-28 06:22:04 EDT
Ok, after some investigations and IRC chat it turns out that X compose sequences work in all of these cases by default at least with Finnish:

- change language from GNOME's Region and Language settings
- change locale setting in /etc/sysconfig/i18n
- change locale setting in $HOME/.i18n

What didn't work was setting locale in shell init script (e.g., $HOME/.bash_profile or $HOME/.zprofile). This is not going to change.

Closing, thanks.