Bug 700513

Summary: Japanese input method cannot be enabled in mozc dictionary tool
Product: [Fedora] Fedora Reporter: Takehiko Abe <keke>
Component: imsettingsAssignee: Akira TAGOH <tagoh>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 15CC: i18n-bugs, tagoh
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: imsettings-1.2.3-1.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-10 09:28:55 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Takehiko Abe 2011-04-28 11:08:16 EDT
Japanese input method cannot be enabled in mozc dictionary tool when it is invoked via the ibus mozc menu. (It works fine if invoked from command line.)

Name        : mozc
Version     : 1.1.690.102
Release     : 0.2.20110419svn.fc15
Architecture: x86_64
Comment 1 Akira TAGOH 2011-05-08 23:07:38 EDT
I thought I could reproduce this problem before, but I can't now. it works for me. when you open a popup menu through the right click, what does it say which IM is used for Qt?
Comment 2 Takehiko Abe 2011-05-09 01:04:08 EDT
> I thought I could reproduce this problem before, but I can't now. it works for
> me. when you open a popup menu through the right click, what does it say which
> IM is used for Qt?

I cannot figure out which popup menu you want me to check. I'm using
mozc on gnome-shell (ibus-gtk2 ibus-gtk3). Is it still relevant?

mozc-1.1.690.102-0.2.20110419svn.fc15.x86_64
Comment 3 Akira TAGOH 2011-05-09 02:15:05 EDT
Click "Add" button say, blinking a cursor on the input field, right-click there. you'll see "Select IM" in the pop up menu. please make sure if you have "ibus" selected there.
Comment 4 Takehiko Abe 2011-05-09 04:59:24 EDT
(In reply to comment #3)
> Click "Add" button say, blinking a cursor on the input field, right-click
> there. you'll see "Select IM" in the pop up menu.

hmm... I don't see it. There are standard undo/redo/cut/copy/paste/delete/select-all items but nothing else.
Comment 5 Akira TAGOH 2011-05-09 06:11:19 EDT
Guess you may have only one qt immodule installed then. though it even works with xim though.

I'm not sure if it would helps but can you try installing ibus-qt and re-log into your desktop and input on the dictionary tool?
Comment 6 Takehiko Abe 2011-05-09 09:29:47 EDT
> Guess you may have only one qt immodule installed then. though it even works
> with xim though.

I have gtk2-immodule-xim installed and that's the only package that
contains "immodule" in its name.

> I'm not sure if it would helps but can you try installing ibus-qt and re-log
> into your desktop and input on the dictionary tool?

It helped. ibus-qt gives me the missing "Select IM" menu and selecting
'Ibus' enabled japanese input.

It does not stick though -- the IM selection reverts back to "XIM".

That is when the dictionary tool is invoked from the gnome-shell menu.
The selection seem to revert to 'Ibus' if invoked from commandline
("/usr/libexec/mozc_tool --mode=dictionary_tool").

'XIM' does work for me when the dictionary tool is invoked from commandline.
Comment 7 Akira TAGOH 2011-05-09 22:19:58 EDT
See your $HOME/.imsettings.log. you can find out which immodules are used for Qt.

(In reply to comment #6)
> It does not stick though -- the IM selection reverts back to "XIM".

Changing IM from the menu is instant setting. no wonder it's back to xim.

> 
> That is when the dictionary tool is invoked from the gnome-shell menu.
> The selection seem to revert to 'Ibus' if invoked from commandline
> ("/usr/libexec/mozc_tool --mode=dictionary_tool").
> 
> 'XIM' does work for me when the dictionary tool is invoked from commandline.

Does the input work with "ibus" when you bring it up from the menu?
Comment 8 Takehiko Abe 2011-05-10 01:14:19 EDT
(In reply to comment #7)
> See your $HOME/.imsettings.log. you can find out which immodules are used for
> Qt.

It says 'ibus'.

| imsettings information
| ==========================
| Is DBus enabled: yes
| Is imsettings enabled: yes
| Is GTK+ supported: no
| Is Qt supported: no
| DESKTOP_SESSION: gnome
| DISABLE_IMSETTINGS: 
| IMSETTINGS_DISABLE_DESKTOP_CHECK: 
| DBUS_SESSION_BUS_ADDRESS: unix:abstract=/tmp/dbus-...
| GTK_IM_MODULE: ibus
| QT_IM_MODULE: ibus
| XMODIFIERS: @im=ibus
| IMSETTINGS_MODULE: IBus
| IMSETTINGS_INTEGRATE_DESKTOP: yes

> Does the input work with "ibus" when you bring it up from the menu?

Yes.
Comment 9 Akira TAGOH 2011-05-10 01:27:38 EDT
Hm, and XIM is used by default on the dictionary tool anyway? if you have $HOME/.config/Trolltech.conf, try grep DefaultInputMethod $HOME/.config/Trolltech.conf and see what it says.
Comment 10 Takehiko Abe 2011-05-10 05:07:41 EDT
(In reply to comment #9)
> Hm, and XIM is used by default on the dictionary tool anyway? 

Yes, when it is invoked from the menu. If invoked from commandline, it
defaults to Ibus.

> if you have
> $HOME/.config/Trolltech.conf, try grep DefaultInputMethod
> $HOME/.config/Trolltech.conf and see what it says.

grep returns none:

$ grep DefaultInputMethod ~/.config/Trolltech.conf 
$
Comment 11 Akira TAGOH 2011-05-10 05:52:14 EDT
Have you restarted your desktop once you installed ibus-qt? since what Qt immodules are used is determined by QT_IM_MODULE environment variable, it won't happens if you do restart certainly. see strings /proc/<pid>/environ say for the process being brought up from the menu. guess you may not see QT_IM_MODULE=ibus there. then good to check XMODIFIERS too. that may explains why it doesn't work for you. again, even "XIM" works for me.
Comment 12 Takehiko Abe 2011-05-11 02:38:42 EDT
> see strings /proc/<pid>/environ say for
> the process being brought up from the menu. guess you may not see
> QT_IM_MODULE=ibus there. then good to check XMODIFIERS too. 

You are right. I see neither.

But both are present if the tool is invoked with command
"/usr/libexec/mozc_tool --mode=dictionary_tool" either from gnome-terminal
or from run command dialog (alt+F2). (And japanese input works fine.)
Comment 13 Akira TAGOH 2011-05-11 03:23:51 EDT
how about it in ibus-engine-mozc and ibus-daemon? the environment variables in the child process is inherited from the parent process. if you don't have both, that would means you don't have both in even the parent process though.
Comment 14 Takehiko Abe 2011-05-11 04:33:22 EDT
> how about it in ibus-engine-mozc and ibus-daemon? the environment variables in
> the child process is inherited from the parent process. if you don't have both,
> that would means you don't have both in even the parent process though.

Neither has those two environmental variables. And their parent process --
imsettings-daemon -- does not have them too.
Comment 15 Akira TAGOH 2011-05-11 07:00:59 EDT
Hmm, ok. let me try to fix it. for workaround, it may works after installing imsettings-qt package.
Comment 16 Fedora Update System 2011-05-31 06:57:36 EDT
imsettings-1.2.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/imsettings-1.2.3-1.fc15
Comment 17 Fedora Update System 2011-06-02 15:12:18 EDT
Package imsettings-1.2.3-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing imsettings-1.2.3-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/imsettings-1.2.3-1.fc15
then log in and leave karma (feedback).
Comment 18 Takehiko Abe 2011-06-03 04:04:15 EDT
The update fixed the problem. Thank you.
Comment 19 Fedora Update System 2011-06-10 09:28:44 EDT
imsettings-1.2.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.