This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 700963

Summary: Cannot start libvirtd
Product: [Fedora] Fedora Reporter: Javier Ramirez <javilinux>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: rawhideCC: aquini, berrange, clalance, crobinso, itamar, jforbes, laine, veillard, virt-maint
Target Milestone: ---Flags: laine: needinfo?
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-05-02 14:43:28 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Javier Ramirez 2011-04-29 18:35:56 EDT
Description of problem:

libvirtd is not starting and is not showing any useful error message

Version-Release number of selected component (if applicable):
libvirt-python-0.8.8-4.fc15.x86_64
qemu-kvm-0.14.0-7.fc15.x86_64
kernel-2.6.38.3-18.fc15.x86_64
libvirt-client-0.8.8-4.fc15.x86_64
libvirt-0.8.8-4.fc15.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Try to start libvirtd running "service libvirtd start"
  
Actual results:
Error message:
[root@oldie systemd]# service libvirtd start
Starting libvirtd (via systemctl):  Job failed. See system logs and 'systemctl status' for details.
                                                           [FAILED
And the following error at /var/log/messages:
Apr 30 00:30:19 oldie systemd[1]: libvirtd.service: control process exited, code=exited status=1
Apr 30 00:30:19 oldie systemd[1]: Unit libvirtd.service entered failed state.

Expected results:
libvirtd to start

Additional info:
kvm modules are loaded:
[root@oldie systemd]# lsmod | grep kvm
kvm_intel              43336  0 
kvm                   306680  1 kvm_intel
Comment 1 Javier Ramirez 2011-05-01 03:51:23 EDT
Hi,

I found that the problem was a buggy installation of fedora. If I try to run libvirtd manually I get the following error:


libvirtd: error while loading shared libraries: 
                /usr/lib64/libvirt-qemu.so.0: file too short

And that turns out that /usr/lib64/libvirt-qemu.so.0.8.8 was an empty file.

After reinstalling using yum, now I get other empty files so I would say the problem is not libvirt related.

Feel free to close the bugzilla.