Bug 701849

Summary: [abrt] libreoffice-calc-1:3.3.2.2-6.fc15: Font::Font(Font const&): Process /usr/lib/libreoffice/program/scalc.bin was killed by signal 11 (SIGSEGV)
Product: [Fedora] Fedora Reporter: Tomas Dabašinskas <tdabasin>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: caolanm, dtardon, ltinkl
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:3099b3efe8e10976a05210deccaebbde9c5067c7
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-05-03 23:48:21 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
File: backtrace none

Description Tomas Dabašinskas 2011-05-03 23:37:43 EDT
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 33460 bytes
cmdline: /usr/lib/libreoffice/program/scalc.bin -calc
component: libreoffice
Attached file: coredump, 67940352 bytes
crash_function: Font::Font(Font const&)
executable: /usr/lib/libreoffice/program/scalc.bin
kernel: 2.6.38.2-9.fc15.i686
package: libreoffice-calc-1:3.3.2.2-6.fc15
rating: 3
reason: Process /usr/lib/libreoffice/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Lovelock)
time: 1304480180
uid: 500

comment
-----
Simply started office calc, tried opening file same problem, when running from command line:

$ soffice -calc
/usr/bin/soffice: line 163:  1871 Segmentation fault      (core dumped) "$sd_prog/$sd_binary" "$@"

How to reproduce
-----
Office calc fails to start (was working before)

1. Tried running office calc
2.
3.
Comment 1 Tomas Dabašinskas 2011-05-03 23:37:46 EDT
Created attachment 496680 [details]
File: backtrace
Comment 2 Tomas Dabašinskas 2011-05-03 23:48:21 EDT
deleted ~/.libreoffice, works now
Comment 3 David Tardon 2011-05-04 04:46:46 EDT
My bad, I forgot to add the patch fixing this crash into libreoffice 3.3 as well. It will be okay in libreoffice-3.3.2.2-7.fc15 .

*** This bug has been marked as a duplicate of bug 658304 ***