Bug 7020

Summary: sort doesn't work
Product: [Retired] Red Hat Linux Reporter: Timur <timur>
Component: textutilsAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-11-22 17:18:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Timur 1999-11-15 17:43:16 UTC
sort doesn't work in binary mode properly.
Input:
ADa
aba
ADc
Output:
aba
ADa
ADc
Correct output:
ADa
ADc
aba
Just figure out, how many people uses sort in their scripts. In example,
vim+ctags doesn't work, cuz ctags uses sort as external sort program, and
vim by default doesn't understand unsorted tags files.

Comment 1 Bill Nottingham 1999-11-15 19:11:59 UTC
sort is paying attention to locales now. What's your locale setting?

Comment 2 Bernhard Rosenkraenzer 1999-11-22 17:18:59 UTC
It's not a bug, it's a feature - the new sort is POSIX compliant, therefore
some flags have changed. (See info sort)

Comment 3 Jeff Johnson 2000-03-11 18:00:59 UTC
*** Bug 10117 has been marked as a duplicate of this bug. ***

Comment 4 sidlon 2000-03-11 19:00:59 UTC
While this isn't a bug in sort, isn't it a problem with the RH6.1 distribution that the default installation doesn't set the LC_ALL variable to work with sort 2.0?  Considering how many people depend on the sort command, it shouldn't take additional tinkering to install RH and have a usable sort.