Bug 702410

Summary: lvremove of snapshot produces multipathd "uevent trigger error"
Product: Red Hat Enterprise Linux 5 Reporter: Dave Wysochanski <dwysocha>
Component: device-mapper-multipathAssignee: Ben Marzinski <bmarzins>
Status: CLOSED ERRATA QA Contact: Gris Ge <fge>
Severity: high Docs Contact:
Priority: high    
Version: 5.3CC: agk, bmarzins, bmr, dwysocha, fge, heinzm, mbroz, prajnoha, prockai, rprice, zkabelac
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-02-21 01:34:46 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Analysis of messages, based on device-mapper-multipath source
none
Messages file, trimmed for 500 lines before / after "uevent trigger error" none

Description Dave Wysochanski 2011-05-05 11:25:56 EDT
Description of problem:
Customer reported a backup application that periodically removes snapshots results in multipathd sending "uevent trigger error" messages.

I investigated this, and will attach my results.  Net-net: this is multipathd processing uevents from LVM.

If possible, multipathd should filter out and not process LVM events, or better error messages should be given.


Version-Release number of selected component (if applicable):
RHEL5.3: device-mapper-multipath-0.4.7-23.el5-x86_64

How reproducible:
Somewhat hard to reproduce - probably related to timing of LVM / multipathd uevent handling.
Comment 1 Dave Wysochanski 2011-05-05 11:28:48 EDT
Created attachment 497132 [details]
Analysis of messages, based on device-mapper-multipath source
Comment 2 Dave Wysochanski 2011-05-05 11:32:26 EDT
Created attachment 497133 [details]
Messages file, trimmed for 500 lines before / after "uevent trigger error"

This is a trimmed version of the messages file from the system.  Full information on the system, including a sosreport and messages file, can be obtained from the case.
Comment 4 Ben Marzinski 2011-10-11 18:40:08 EDT
I've kept multipathd from printing an error in this case.
Comment 6 Gris Ge 2012-01-10 02:57:06 EST
Tried 1000 times for these two scripts, no luck to reproduce on RHEL 5.7 GA (device-mapper-multipath-0.4.7-46.el5)

for LVM:
===
for X in `seq 1 1000`;do
  lvcreate -n tmp_test -L 4M VolGroup00
  service multipathd start
  sleep 1
  lvremove /dev/mapper/VolGroup00-tmp_test -f
  sleep 1
  service multipathd stop
  if [ "$(grep "uevent trigger error" /var/log/messages)CHK" != "CHK" ];then
      grep "uevent trigger error" /var/log/messages
      break
  fi
done
====

for dm
====
for X in `seq 1 1000`;do
  echo "0 1024000 zero" | dmsetup create zero_test_dm
  ls /dev/mapper/
  service multipathd start
  sleep 1
  dmsetup remove zero_test_dm
  ls /dev/mapper/
  sleep 1
  service multipathd stop
  if [ "$(grep "uevent trigger error" /var/log/messages)CHK" != "CHK" ];then
      grep "uevent trigger error" /var/log/messages
      break
  fi
done
====

Patch has been applied into a tar file. no way for me code review.

I also tried above commands on new package: device-mapper-multipath-0.4.7-48.el5, no uevent error message found.

SanityOnly.
Comment 7 errata-xmlrpc 2012-02-21 01:34:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0166.html